General Discussion
  >> Broadband Quality Monitor


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User TooUnCool
(newbie) Fri 11-Aug-17 12:47:45
Print Post

Strange problem


[link to this post]
 
This is my first post and I have been careful to search the forum to try to find an answer, but couldn't. Please be kind if I have missed the 'bleeding obvious"!

My Quality Monitor was working fine using a DDNS address then all of a sudden everything went red, although the connection was still up. I changed the DDNS address to the WAN IP address allocation (which i recently changed to static, so no real need for DDNS anyway), but it hasn't made a difference.

The router is a Draytek 2860 and I have unchecked (it was never checked) "Disable ping from Internet" in Management. I can ping the router just fine via the IP or DDNS addresses.

Can someone tell me what I am missing here? I am using Origin Broadband (I know, I know...) although that shouldn't make a difference unless they have found some cunning way of blocking Thinkbroadband given all the complaints they receive after people start using your excellent tool....

Help much appreciated!
Administrator MrSaffron
(staff) Fri 11-Aug-17 12:55:50
Print Post

Re: Strange problem


[re: TooUnCool] [link to this post]
 
When you say you can ping your IP is that from a connection other than your actual origin line?

Since I cannot ping what I believe is you

The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
Standard User TooUnCool
(newbie) Fri 11-Aug-17 16:46:50
Print Post

Re: Strange problem got stranger, then solved


[re: MrSaffron] [link to this post]
 
You are totally correct, I was pinging from my own network, in my ignorance thinking that if I use the WAN IP or DDNS address that it will route out over the internet. My bad....

So I did some more digging and uncovered an even stranger problem, possibly even a bug in the Draytek firmware. Here's what I did.

1. Checked the syslog (which I should have done before) and noticed that the ICMP requests from you were actually hitting a device on my network (192.168.1.4), not the router.

2. Checked the NAT/Port Forwarding settings and noticed that in one case I had indicated that TCP/UDP should be forwarded, but left the ports as default which is 0 (can post screenshots if anyone is interested and I am not being clear).

When I removed TCP/UDP and set it back to null (ie not used), all of a sudden I can ping using Wormly. That is surely a bug in the Draytek firmware which should, at least, stop you entering a protocol without changing the port number from 0.

Or is forwarding TCP/UDP to port 0 for a particular address the same as telling a router to forward ICMP pings to that IP address?


Register (or login) on our website and you will not see this ad.

Administrator MrSaffron
(staff) Sat 12-Aug-17 11:27:51
Print Post

Re: Strange problem got stranger, then solved


[re: TooUnCool] [link to this post]
 
MIght be just doing all ports when you set zero and its a DMZ type operation, i..e all unsolicited traffic goes to the IP you set

The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
  Print Thread

Jump to