User comments on ISPs
  >> BT Broadband


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User Jnaro
(newbie) Thu 12-Mar-15 19:21:45
Print Post

Lower speed


[link to this post]
 
Noticed much slower speedtests the last few days. Login to the modem (HG612) to find the attainable rate is 83mbit with 6.2dB SNR but the actual rate is only 67710 downstream. It's always been 79999, so I'm wondering what's going on.


# xdslcmd info --pbParams
xdslcmd: ADSL driver and PHY status
Status: Showtime
Retrain Reason: 0
Max: Upstream rate = 33957 Kbps, Downstream rate = 83464 Kbps
Path: 0, Upstream rate = 19999 Kbps, Downstream rate = 67710 Kbps

Discovery Phase (Initial) Band Plan
US: (0,95) (868,1207) (1972,2783)
DS: (32,859) (1216,1963) (2792,3971)
Medley Phase (Final) Band Plan
US: (0,95) (868,1207) (1972,2783)
DS: (32,859) (1216,1963) (2792,3971)
VDSL Port Details Upstream Downstream
Attainable Net Data Rate: 33957 kbps 83464 kbps
Actual Aggregate Tx Power: - 3.1 dBm 13.0 dBm
============================================================================
VDSL Band Status U0 U1 U2 U3 D1 D2 D3
Line Attenuation(dB): 2.4 11.5 17.2 N/A 6.3 14.3 22.6

Signal Attenuation(dB): 2.4 10.7 16.1 N/A 6.3 14.3 22.6

SNR Margin(dB): 12.2 12.1 12.1 N/A 6.3 6.2 6.2

TX Power(dBm): -17.2 -32.7 -3.3 N/A 9.3 8.0 7.0

#

Edited by Jnaro (Thu 12-Mar-15 19:36:49)

Standard User RobertoS
(elder) Thu 12-Mar-15 20:22:19
Print Post

Re: Lower speed


[re: Jnaro] [link to this post]
 
Please give us the output from xdslcmd info --show

smile

My broadband basic info/help site - www.robertos.me.uk. Domains,site and mail hosting - Tsohost.
Connection - Plusnet UnLim Fibre (FTTC). Sync ~ 53.4 (interleaved)/15.6Mbps @ 600m. - IPv4BQM IPv6BQM
Standard User tommy45
(knowledge is power) Thu 12-Mar-15 20:48:04
Print Post

Re: Lower speed


[re: Jnaro] [link to this post]
 
My guess would be that DLM has clobbered your connection can you browse to the following web address BTW speed/IP profile checker you can ignore the bumph in red, run the speed test, and then click on the next button, and it should eventually give you a graphical view of the speedtest and what your ip profile is , 67-70mbpswhich would represent a common 1st step by DLM a loss of around 8-10mbps in sync and an extra 7-8ms in base latency , which your full router stats will confirm more accurately

Edited by tommy45 (Thu 12-Mar-15 20:50:32)


Register (or login) on our website and you will not see this ad.

Standard User Jnaro
(newbie) Thu 12-Mar-15 21:27:56
Print Post

Re: Lower speed


[re: tommy45] [link to this post]
 
download 63 (-13)
upload 14 (-4)
latency 49 (used to be 16)
Standard User Jnaro
(newbie) Thu 12-Mar-15 21:29:18
Print Post

Re: Lower speed


[re: RobertoS] [link to this post]
 
# xdslcmd info --show
xdslcmd: ADSL driver and PHY status
Status: Showtime
Retrain Reason: 0
Max: Upstream rate = 33861 Kbps, Downstream rate = 83464 Kbps
Path: 0, Upstream rate = 19999 Kbps, Downstream rate = 67710 Kbps

Link Power State: L0
Mode: VDSL2 Annex B
VDSL2 Profile: Profile 17a
TPS-TC: PTM Mode
Trellis: U:ON /D:ON
Line Status: No Defect
Training Status: Showtime
Down Up
SNR (dB): 6.2 12.1
Attn(dB): 0.0 0.0
Pwr(dBm): 13.0 -3.1
VDSL2 framing
Path 0
B: 45 29
M: 1 1
T: 64 64
R: 14 10
S: 0.0216 0.0476
L: 22211 6717
D: 1217 673
I: 60 40
N: 60 40
Counters
Path 0
OHF: 5893400 1789628
OHFErr: 4 2
RS: 1508709892 3838831
RSCorr: 1475 6076
RSUnCorr: 37 0

Path 0
HEC: 4 0
OCD: 0 0
LCD: 0 0
Total Cells: 1065323457 0
Data Cells: 4437413 0
Drop Cells: 0
Bit Errors: 0 0

ES: 1 1
SES: 0 0
UAS: 17 17
AS: 8179

Path 0
INP: 3.00 4.00
PER: 1.38 4.57
delay: 7.00 8.00
OR: 138.81 73.46

Bitswap: 496 567

#
Standard User tommy45
(knowledge is power) Thu 12-Mar-15 22:09:58
Print Post

Re: Lower speed


[re: Jnaro] [link to this post]
 
In reply to a post by Jnaro:
# xdslcmd info --show
xdslcmd: ADSL driver and PHY status
Status: Showtime
Retrain Reason: 0
Max: Upstream rate = 33861 Kbps, Downstream rate = 83464 Kbps
Path: 0, Upstream rate = 19999 Kbps, Downstream rate = 67710 Kbps

Link Power State: L0
Mode: VDSL2 Annex B
VDSL2 Profile: Profile 17a
TPS-TC: PTM Mode
Trellis: U:ON /D:ON
Line Status: No Defect
Training Status: Showtime
Down Up
SNR (dB): 6.2 12.1
Attn(dB): 0.0 0.0
Pwr(dBm): 13.0 -3.1
VDSL2 framing
Path 0
B: 45 29
M: 1 1
T: 64 64
R: 14 10
S: 0.0216 0.0476
L: 22211 6717
D: 1217 673
I: 60 40
N: 60 40
Counters
Path 0
OHF: 5893400 1789628
OHFErr: 4 2
RS: 1508709892 3838831
RSCorr: 1475 6076
RSUnCorr: 37 0

Path 0
HEC: 4 0
OCD: 0 0
LCD: 0 0
Total Cells: 1065323457 0
Data Cells: 4437413 0
Drop Cells: 0
Bit Errors: 0 0

ES: 1 1
SES: 0 0
UAS: 17 17
AS: 8179

Path 0
INP: 3.00 4.00
PER: 1.38 4.57
delay: 7.00 8.00
OR: 138.81 73.46

Bitswap: 496 567

#
Your Upstream sync speed is the max for the GEA product 80/20 ,You are seeing the actual throughput at the time you ran a speed test, try FTP uploads or a different speedtest, i also notice that your upstream is also interleaved why that is i don't know, unless there was a lot of errors affecting it, or it's down to the DLM stability profile that is chosen by your ISP, but with a max sync rate i would expect the throughput to be higher, 18-19.5mbps maybe

Edited by tommy45 (Thu 12-Mar-15 22:11:35)

Standard User Jnaro
(newbie) Thu 12-Mar-15 22:40:37
Print Post

Re: Lower speed


[re: tommy45] [link to this post]
 
I don't really care about upload, but I always got 18mbps up on speedtest.net. download and latency is my main concern.
Standard User RobertoS
(elder) Fri 13-Mar-15 00:22:24
Print Post

Re: Lower speed


[re: tommy45] [link to this post]
 
In reply to a post by tommy45:
... run the speed test, and then click on the next button ....
There isn't one. You meant Further diagnostics.

My broadband basic info/help site - www.robertos.me.uk. Domains,site and mail hosting - Tsohost.
Connection - Plusnet UnLim Fibre (FTTC). Sync ~ 53.4 (interleaved)/15.6Mbps @ 600m. - IPv4BQM IPv6BQM

Edited by RobertoS (Fri 13-Mar-15 00:46:36)

Standard User RobertoS
(elder) Fri 13-Mar-15 00:45:10
Print Post

Re: Lower speed


[re: Jnaro] [link to this post]
 
You might not normally care about upload, but in this case it may be relevant to finding the problem. It is unusual to see the D: 1217 673 line which is Interleaving Depth with anything other than 1 (= Fast Path) for the upload. See mine:-

# xdslcmd info --show
xdslcmd: ADSL driver and PHY status
Status: Showtime
Retrain Reason: 0
Last initialization procedure status: 0
Max: Upstream rate = 15537 Kbps, Downstream rate = 60632 Kbps
Bearer: 0, Upstream rate = 15585 Kbps, Downstream rate = 53385 Kbps

Link Power State: L0
Mode: VDSL2 Annex B
VDSL2 Profile: Profile 17a
TPS-TC: PTM Mode(0x0)
Trellis: U:ON /D:ON
Line Status: No Defect
Training Status: Showtime
Down Up
SNR (dB): 5.6 5.6
Attn(dB): 19.5 0.0
Pwr(dBm): 13.6 7.4
VDSL2 framing
Bearer 0
MSGc: 18 25
B: 51 237
M: 1 1
T: 64 64
R: 12 16
S: 0.0310 0.4858
L: 16520 4183
D: 1045 1
I: 64 127
N: 64 254
Counters
Bearer 0
OHF: 172791080 1098761
OHFErr: 1147 204
RS: 1284716142 2780988
RSCorr: 2790787 9315
RSUnCorr: 37233 0

Bearer 0
HEC: 9483 0
OCD: 369 0
LCD: 369 0
Total Cells: 958445196 0
Data Cells: 59099310 0
Drop Cells: 0
Bit Errors: 0 0

ES: 53 128
SES: 0 0
UAS: 242 242
AS: 344081

Bearer 0
INP: 3.00 0.00
INPRein: 0.00 0.00
delay: 8 0
PER: 1.99 7.80
OR: 96.42 31.78
AgR: 53481.08 15617.01

Bitswap: 268187/268188 8092/8106

Take a look at this post by a very knowledgeable chap.

I've never seen a downstream "Delay" of less than 8ms. (Except of course for 1). As he says, it's the usual first step. Nor do I recall the upstream being other than 0.

What we do know is that interleaving does lower the "Path" downstream (actual sync) by 10Mbps or so, and incidentally increase the "Max" crazy.

So we know more about the symptoms. But we don't know why that heavy interleaving has been imposed. That's what we have to work on.

Sorry, I'm tired now and brain-fogged.

My broadband basic info/help site - www.robertos.me.uk. Domains,site and mail hosting - Tsohost.
Connection - Plusnet UnLim Fibre (FTTC). Sync ~ 53.4 (interleaved)/15.6Mbps @ 600m. - IPv4BQM IPv6BQM
Standard User Jnaro
(newbie) Fri 13-Mar-15 04:22:11
Print Post

Re: Lower speed


[re: RobertoS] [link to this post]
 
I have no clue. All I know is problems with disconnects started quite recently but I didn't notice loss of speed until Wednesday. This is an old install (6 years+) - I'm on one of the original FTTC trial exchanges, so maybe the cabinet cards are flaking out.

Will attempt to escalate with BT re: upstream interleaving. That is odd.


Sync has been 78000-79999 until this
  Print Thread

Jump to