Technical Discussion
  >> DSL Hardware Discussion


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User ncudmore
(newbie) Wed 13-Apr-11 14:21:05
Print Post

Cisco dsl firmware update


[link to this post]
 
Hi,

Changed my ISP from BT to BE, and so now have the ADSL2+ connection.

So, redoing the whole config on my cisco 877, and had major problems trying to connect to BE, when it worked find on BT (ADSL).

Suspect that the firmware needed update to talk to ADSL2+ so copied the new firmware (adsl_alc_firmware.4-10-9.bin) to the flash on the 877 and renamed it to adsl_alc_20190.bin. Rebooted the device but it still shows the FW Source as embedded-

Operation FW: AMR-3.0.014.bin
FW Source: embedded

the IOS is (C870-ADVIPSERVICESK9-M), Version 12.4(15)T2, RELEASE SOFTWARE (fc7)

Even wiped the whole config, and then powered off the router, made a cup of really strong tea then powered it up and get the same result...


Anyone point me in the right direction?
Standard User demonuk
(eat-sleep-adslguide) Wed 13-Apr-11 18:44:54
Print Post

Re: Cisco dsl firmware update


[re: ncudmore] [link to this post]
 
Hi,

In reply to a post by ncudmore:
Suspect that the firmware needed update to talk to ADSL2+ so copied the new firmware (adsl_alc_firmware.4-10-9.bin) to the flash on the 877 and renamed it to adsl_alc_20190.bin. Rebooted the device but it still shows the FW Source as embedded-


4.10.9 isn't actually for the 877, it's for the 836 if memory serves - the latest 877 firmware on cisco.com is 4.0.17, which is actually quite old.

If you've got SMARTnet, I'd recommend raising a call with the TAC however, as they have a much newer version available.

--
Martyn Dewar
Powered by: ZN

Edited by demonuk (Wed 13-Apr-11 18:45:15)

Anonymous
(Unregistered)Wed 13-Apr-11 23:38:05
Print Post

Re: Cisco dsl firmware update


[re: demonuk] [link to this post]
 
Ahh....

In reply to a post by demonuk:
the latest 877 firmware on cisco.com is 4.0.17, which is actually quite old.


Well I've now got IOS v15 & DSL Firmware 4.0.18 only I can't get SDM 2.5 to talk to IOS v15.. But, I've been told there is also v4.0.195 out there as well.

So before I end up writing the whole darn config manually, has anyone got a good known combo with ADSL2+, of IOS and firmware I can start from?


Register (or login) on our website and you will not see this ad.

Standard User demonuk
(eat-sleep-adslguide) Thu 14-Apr-11 08:34:16
Print Post

Re: Cisco dsl firmware update


[re: Anonymous] [link to this post]
 
In reply to a post by Anonymous:
Well I've now got IOS v15 & DSL Firmware 4.0.18 only I can't get SDM 2.5 to talk to IOS v15.. But, I've been told there is also v4.0.195 out there as well.

So before I end up writing the whole darn config manually, has anyone got a good known combo with ADSL2+, of IOS and firmware I can start from?
I wouldn't recommend SDM, as the software is woefully poor.

If you do need a GUI, try Cisco Configuration Professional which is a little bit better, and is more up-to-date too.

I'm running IOS 15.0(1)XA5 and DSL firmware 9.0.140 here (on ADSL2+), and it works like a charm. smile

--
Martyn Dewar
Powered by: ZN
Standard User Rockh
(eat-sleep-adslguide) Thu 14-Apr-11 18:00:05
Print Post

Re: Cisco dsl firmware update


[re: demonuk] [link to this post]
 
interface ATM0
 mac-address ****MAC ADDRESS OF BE BOX****
 no ip address
 ip virtual-reassembly
 no atm ilmi-keepalive
 dsl operating-mode adsl2+ 
!
interface ATM0.1 point-to-point
 description ADSL2+ o2broadband
 mtu 1500
 ip address ****BE IP ADDRESS****
 ip nat outside
 ip virtual-reassembly
 atm route-bridged ip
 pvc 0/101 
  oam-pvc manage
  encapsulation aal5snap
 !
!
interface Vlan1
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Vlan2
 ip address 10.0.0.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface BVI1
 no ip address
 ip nat inside
 ip virtual-reassembly
 shutdown
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 ****BE NEXT HOP IP ADDRESS****
ip route 10.0.0.0 255.255.255.0 Vlan2

From my 1801, found that it syncs quite a bit lower than the provided Thomson router, now run a Netgear DG834GT in bridge mode.

Dave
  Print Thread

Jump to