Technical Discussion
  >> DSL Hardware Discussion


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User AdamF
(member) Wed 04-May-11 23:27:48
Print Post

Help re IOS configuration


[link to this post]
 
I currently have a Cisco 831 acting as my main router. An ethernet ADSL modem is attached to the 831's WAN interface, so the latter acquires a public IP address from my ISP. The ISP in queston is O2, who use RFC 1483 rather then PPP. So, the bones of the configuration on the 831 are as follows:

ip dhcp excluded-address 10.10.10.1 10.10.10.9
!
ip dhcp pool CLIENT
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip access-group 100 in
ip nat inside
ip virtual-reassembly
ipv6 address 2001:470:1F09:1728::/64
ipv6 enable
!
interface Ethernet1
ip address dhcp client-id Ethernet1
ip access-group 101 in
ip nat outside
ip inspect SDM_LOW out
ip virtual-reassembly
duplex auto
!

The ethernet ADSL modem has a config / stats page at address 10.0.0.138, and I would like to be able to view this from clients on the LAN side. If I temporarily set the address of Ethernet1 to 10.0.0.1, I can see the modem's page but obviously I lose internet connectivity. A permanent solution would be to give Ethernet1 a secondary address of 10.0.0.1, but IOS will not allow this as it is acquiring its primary address via DHCP.

Any ideas if there is another way of achiving this ?

Thanks.
Standard User camieabz
(legend) Thu 05-May-11 00:22:32
Print Post

Re: Help re IOS configuration *DELETED*


[re: AdamF] [link to this post]
 
Post deleted by camieabz
Standard User Rockh
(eat-sleep-adslguide) Thu 05-May-11 18:09:39
Print Post

Re: Help re IOS configuration


[re: AdamF] [link to this post]
 
You need to set a static route pointing to 10.0.0.138 via eth 0

Dave


Register (or login) on our website and you will not see this ad.

Standard User Sandgrounder
(knowledge is power) Thu 05-May-11 19:20:51
Print Post

Re: Help re IOS configuration


[re: AdamF] [link to this post]
 
Not sure I have understood all of your post.

But you seem to to have two overlapping subnet address ranges:
10.0.0.x - presumably with a standard mask of 255.0.0.0
and
10.10.10.x - with a non-standard mask of 255.255.255.0



Line One:- Zen - DrayTek Vigor 2600VG
Line Two:- EntaNet (Aquiss) - DrayTek Vigor 2600
Standard User AdamF
(member) Thu 05-May-11 23:19:34
Print Post

Re: Help re IOS configuration


[re: Rockh] [link to this post]
 
I think the modem uses 255.255.255.0 so the subjects do not overlap.

I have tried a static entry to 10.0.0.138, but it does not seem to have any effect.
  Print Thread

Jump to