General Discussion
  >> Fibre Broadband


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User caffn8me
(knowledge is power) Wed 20-Jun-12 20:54:00
Print Post

Cisco 887VA


[link to this post]
 
It has taken me far less time than expected to get this running on FTTC - inspite of not using the web interface smile

There is a noticeable speed increase over the BT Openreach Huawei modem. The estimated download speed from the BT Wholesale DSL Checker was 30.9Mbps with upload at 5.9Mbps.

At the moment, before the training period is up, www.speedtest.net shows downloads at 36.91Mbps and uploads at 7.63Mbps.

Sync is currently at 39719kbps down and 8855kbps up but the Cisco shows the line is capable of even faster connections down;

> Attainable Rate: 45876 kbits/s (down) 8851 kbits/s (up)

It will be interesting to see if the link gets anywhere near that as the service is an "up to 80" from Zen.

We're running with a block of 8 IP addresses and no NAT on the router as that will be handled by a dedicated firewall.

I am absolutely not a Cisco expert but if anyone needs a config for a similar install I am happy to share.

Sarah

--
If I can't drink my bowl of coffee three times daily, then in my torment, I will shrivel up like a piece of roast goat

Spiders on coffee - Badass spiders on drugs
Standard User pete_thomson
(fountain of knowledge) Wed 20-Jun-12 21:10:15
Print Post

Re: Cisco 887VA


[re: caffn8me] [link to this post]
 
Nice to Cisco kit working well. I've used a number of Cisco ADSL routers - including an early 837, a 1721 with a WIC card, a 2600 with a WIC card and an 1800 series - and I always found on regular ADSL lines that they synced a far bit lower than "consumer grade" routers.

When fibre finally gets here (due the end of next week but no sign of any cab work yet) I might consider an 887.

Was
Virgin Media 50Mb/s
53.34Mb/s - 1.65Mb/s - 29ms @ 24/05/2011
http://speedtest.net/result/1310626245.png

Now
Andrews & Arnold
3.48Mb/s - 0.91Mb/s - 27ms
http://speedtest.net/result/1940826652.png
Standard User ionic
(fountain of knowledge) Wed 20-Jun-12 21:33:50
Print Post

Re: Cisco 887VA


[re: caffn8me] [link to this post]
 
I can confirm that these perform better than expected for a cisco DSL device on ADSL2+ as well. I got 10% more out of one of our lines compared to a zyxel p660 with one of these. An 877 on that line generally synced slightly slower than the zyxel!


Register (or login) on our website and you will not see this ad.

Standard User jimwillsher
(fountain of knowledge) Tue 23-Oct-12 21:24:21
Print Post

Re: Cisco 887VA


[re: ionic] [link to this post]
 
Sorry to pull up an old thread, but my friend's local exchange has just been FTTC-enabled. We've bought an 887VA and I wondered if anyone could kindly share their config please?

Many thanks


Jim

PS My own exchange serves just 122 premises, so this will be my only chance to play with fibre smile

My line (not necessarily the line referred to in this post, if any):
Zen 8000 Pro (832 / 8128)
Edinburgh IPSC
Cisco 877 Router
Eclipse > Ace > ADSL24 (Enta) > ADSL24 (Murphx) > AAISP > Zen
Standard User asbokid
(member) Tue 23-Oct-12 21:51:39
Print Post

Re: Cisco 887VA


[re: jimwillsher] [link to this post]
 
Sorry, don't know about Cisco config, (there are details out there, somewhere).

Though the xDSL chipset in the Cisco is essentially identical to the chipset in the Openreach-supplied Huawei HG612. It is the multimode-capable Broadcom BCM6368. Consequently, the performance of the Cisco and the Huawei are likely to be very similar.

Incidentally, a Hungarian hacker called Sipos Csaba has discovered a slightly newer DSL driver blob for the BCM6368 (which perhaps would work for the Cisco, too).

It seems that the DSL driver version currently shipped in the HG612 firmware is A2pv6C030b.d22g:

Text
1
23
4
# xdslcmd --version
xdslcmd version 1.0DSL PHY: AnnexA version - A2pv6C030b.d22g
******* Pass *********


However, Actiontec, a N.American CPE supplier, has included a slightly newer driver version in a GPL'ed source code tarball for its 6368-based devices [1]. That driver version is A2pv6C035f.d22g

Text
1
23
4
# xdslcmd --version
xdslcmd version 1.0DSL PHY: AnnexA version - A2pv6C035f.d22g
******* Pass *********


It looks like a very minor driver revision, but it might just squeeze a couple more bits per hour!

Anyone interested in giving it a whirl?! Sipos has already built some new firmware with the newer driver, if anyone wants to contact him to try it out?

cheers, a

[1] http://peterkieser.com/2011/09/24/actiontec-releases...

Edited by asbokid (Tue 23-Oct-12 21:54:09)

Standard User caffn8me
(knowledge is power) Wed 24-Oct-12 00:43:16
Print Post

Re: Cisco 887VA


[re: jimwillsher] [link to this post]
 
In reply to a post by jimwillsher:
Sorry to pull up an old thread, but my friend's local exchange has just been FTTC-enabled. We've bought an 887VA and I wondered if anyone could kindly share their config please?
Apologies for the slow reply.

Below is a sanitized config for a routed block of IP addresses I am currently running. The router does no NAT and no security as these are handled by a dedicated firewall.

I have upgraded the dialer firmware from that which the router came with. I'm not sure if this is the latest firmware available but will check tomorrow.

!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service internal
service sequence-numbers
!
hostname ********-gw
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
no logging console
enable secret 5 ****************************
enable password 7 ****************************
!
aaa new-model
!
!
aaa authentication login local_authen local
aaa authorization exec local_author local
!
!
!
!
!
aaa session-id common
memory-size iomem 10
clock timezone London 0 0
clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00
!
!
no ip source-route
ip auth-proxy max-login-attempts 5
ip admission max-login-attempts 5
!
!
!
!
!
!
!
!
!
no ip bootp server
ip domain name **********.co.uk
ip name-server 212.23.3.100
ip name-server 212.23.6.100
ip inspect WAAS flush-timeout 10
ip cef
no ipv6 cef
!
!
license udi pid CISCO887VA-K9 sn ***********
!
!
username ******** privilege 15 secret 5 ******************************
!
!
!
!
!
controller VDSL 0
firmware filename flash:vdsl.bin-A2pv6C035d_d23j
modem customUKannexM
modem UKfeature
!
ip tcp synwait-time 10
ip ssh version 2
ip scp server enable
!
!
!
!
!
!
!
!
!
interface Null0
no ip unreachables
!
interface Ethernet0
no ip address
!
interface Ethernet0.101
encapsulation dot1Q 101
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface Vlan1
ip address 217.155.*.* 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
!
interface Dialer0
ip unnumbered Vlan1
no ip redirects
no ip unreachables
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname zen******@zen
ppp chap password 7 *****************
ppp direction callout
no cdp enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 217.155.*.* 255.255.255.248 Vlan1 permanent
!
access-list 100 permit ip 217.155.*.* 0.0.0.7 any
access-list 100 deny ip any any
dialer-list 1 protocol ip permit
!
!
!
!
!
line con 0
exec-timeout 0 0
login authentication local_authen
transport output telnet ssh
line aux 0
line vty 0 4
access-class 100 in
exec-timeout 60 0
password 7 ******************
authorization exec local_author
login authentication local_authen
transport input ssh
!
ntp logging
ntp server ntp2a.mcc.ac.uk prefer
!
end
The lines;
modem customUKannexM
modem UKfeature
are not relevant to VDSL, only ADSL but if you want to run ADSL on a Cisco router they improve operability with BT's network.

I'm not a Cisco expert so there may be other unnecessary bits to the config and it may be lacking certain optimizations.

It does however definitely work on a Zen FTTC connection without the supplied Openreach modem and is fast.

Good luck smile

Sarah

--
If I can't drink my bowl of coffee three times daily, then in my torment, I will shrivel up like a piece of roast goat

Spiders on coffee - Badass spiders on drugs
Standard User caffn8me
(knowledge is power) Wed 24-Oct-12 09:09:43
Print Post

Re: Cisco 887VA


[re: caffn8me] [link to this post]
 
In reply to a post by caffn8me:
I have upgraded the dialer firmware from that which the router came with. I'm not sure if this is the latest firmware available but will check tomorrow.
It seems the latest firmware is A2pv6C035j released 13th March 2012. I haven't tried this yet nor have I managed to find out what differences there are compared to the firmware I'm currently running.

Sarah

--
If I can't drink my bowl of coffee three times daily, then in my torment, I will shrivel up like a piece of roast goat

Spiders on coffee - Badass spiders on drugs
Standard User asbokid
(member) Wed 24-Oct-12 15:58:05
Print Post

Re: Cisco 887VA


[re: asbokid] [link to this post]
 
The Cisco Product Bulletin of 15 May 2012 (v.22) provides more detail:

http://www.cisco-bt-portal.com/iusr/DSL/Product_Bulletin_DSL.pdf

cheers, a
Standard User BatBoy
(legend) Wed 24-Oct-12 16:36:18
Print Post

Re: Cisco 887VA


[re: asbokid] [link to this post]
 
BT Requests the following functionality on the main-screen (or on an easily accessible status screen from the main-screen) to aid with remote trouble-shooting.
Line-Rate Connection negotiation rate [10/100/1000]
Profile details (40M/60M/100M if possible from PPPoE profile debugs??)
Attenuation rate: [Unclear how this can be achieved from a Copper interface?]
PPPoE Negotiation Status & PPPoE WAN IP Address Status (and LAN IP Status)
Packet-transmission : Upstream rate and packet-loss, Down-stream rate and packet-loss.
lol


_____________________________________________________________________________________________ this is not usenet __________________
Standard User balami
(committed) Thu 25-Oct-12 21:10:26
Print Post

Re: Cisco 887VA


[re: caffn8me] [link to this post]
 
Hi,

Do you have a copy of the latest firmware as per this BT specific document:-

http://www.cisco-bt-portal.com/iusr/DSL/Product_Bull...

If so could I beg a copy, (the link in the document doesn't work). Otherwise I'll have to try and get a copy from cisco.

From what I've seen of the box so far it is better than the old 857 / 877 routers.

Thanks,

Mark.
  Print Thread

Jump to