General Discussion
  >> Fibre Broadband


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User philippercival
(fountain of knowledge) Wed 03-Jun-15 20:09:08
Print Post

G.INP and settings


[link to this post]
 
Today I installed the latest hacked firmware for my Huawei modem.

The statistics page of the web interface gives the following:
Connection Status		
Mode 	VDSL2  
Traffic type 	PTM  
DSL synchronization status 	Up  
DSL up time 	0  

	Line Status		
                                     Downstream 	Upstream
Attainable rate (kbit/s)	60292	21570
SNR margin (dB)	17.4	0
Line attenuation (dB)	13.7	7.5
Output power (dBmV)	13.7	7.5

	Statistics		
Path 0
	
Path 1
  	Downstream 	Upstream 	Downstream 	Upstream
Line rate (kbit/s)	60945 	20000 	0 	0 
CRC errors	254 	106 	18 	18 
FEC errors	0 	0 	0 	2 
HEC errors	122 	58 	32 	32


After much reading on this forum I eventualy found the
xsslcmd show command and this is the result:
xdslcmd: ADSL driver and PHY status
Status: Showtime
Retrain Reason: 0
Last initialization procedure status:   0
Max:    Upstream rate = 21570 Kbps, Downstream rate = 60292 Kbps
Bearer: 0, Upstream rate = 20000 Kbps, Downstream rate = 60945 Kbps
Bearer: 1, Upstream rate = 0 Kbps, Downstream rate = 0 Kbps
Link Power State:       L0
Mode:                   VDSL2 Annex B
VDSL2 Profile:          Profile 17a
TPS-TC:                 PTM Mode(0x0)
Trellis:                U:ON /D:ON
Line Status:            No Defect
Training Status:        Showtime
                Down            Up
SNR (dB):        6.2             6.5
Attn(dB):        17.4            0.0
Pwr(dBm):        13.7            7.4
                        VDSL2 framing
                        Bearer 0
MSGc:           -6              -6
B:              243             97
M:              1               1
T:              0               0
R:              10              8
S:              0.1275          0.1554
L:              15939           5457
D:              8               8
I:              254             106
N:              254             106
Q:              8               8
V:              0               2
RxQueue:                48              39
TxQueue:                16              13
G.INP Framing:          18              18
G.INP lookback:         16              13
RRC bits:               24              24
                        Bearer 1
MSGc:           122             58
B:              0               0
M:              2               2
T:              2               2
R:              16              16
S:              8.0000          16.0000
L:              32              16
D:              1               1
I:              32              32
N:              32              32
Q:              0               0
V:              0               0
RxQueue:                0               0
TxQueue:                0               0
G.INP Framing:          0               0
G.INP lookback:         0               0
RRC bits:               0               0
                        Counters
                        Bearer 0
OHF:            0               0
OHFErr:         0               0
RS:             96512040                2201448
RSCorr:         1379            52
RSUnCorr:       0               0
                        Bearer 1
OHF:            192311          193062
OHFErr:         0               0
RS:             1537992         772250
RSCorr:         1               0
RSUnCorr:       0               0

                        Retransmit Counters
rtx_tx:         86465           5
rtx_c:          73              7976
rtx_uc:         0               172

                        G.INP Counters
LEFTRS:         3               79
minEFTR:        60944           19991
errFreeBits:    2871539         1323968581

                        Bearer 0
HEC:            0               0
OCD:            0               0
LCD:            0               0
Total Cells:    362002797               0
Data Cells:     1562451         0
Drop Cells:     0
Bit Errors:     0               0

                        Bearer 1
HEC:            0               0
OCD:            0               0
LCD:            0               0
Total Cells:    0               0
Data Cells:     0               0
Drop Cells:     0
Bit Errors:     0               0

ES:             0               0
SES:            0               0
UAS:            197             197
AS:             3090

                        Bearer 0
INP:            47.00           47.00
INPRein:        0.00            0.00
delay:          0               0
PER:            0.00            0.00
OR:             0.01            0.01
AgR:            61007.61        20102.08

                        Bearer 1
INP:            2.00            4.00
INPRein:        2.00            4.00
delay:          0               0
PER:            16.06           16.06
OR:             63.75           31.87
AgR:            63.75   31.87

Bitswap:        2424/2424               15/15


When I was first connected to FTTC, perhaps three years ago. I got much better speeds and the engineer said it was connected at 73MBps I managed to achieve 63MBps

This gradually fell to about 49MBps

It is now 52 / 13.66 MBps

(the upload speed has been fairly consistent.)

I wonder if some kind sole who understands this raft of figures could have a quick look and tell me if this looks about right.

Thanks in anticipation.

http://speedtest.net/result/2459383290.png

Solar Results
2013 3521kwh,   2014 3435kwh, 2015  1540kwh (so far)
My Broadband Ping
Standard User RobertoS
(elder) Wed 03-Jun-15 20:22:01
Print Post

Re: G.INP and settings


[re: philippercival] [link to this post]
 
G.INP is implemented on that line.

Assuming you are still with Plusnet then I expect your 60945Mbps sync to give you an IP Profile of 58.93Mbps, which should result in a Plusnet Current line speed of 58.9Mbps.

You can confirm the IP Profile using the Further Diagnostics of the BT Wholesale Performance Test. Current line speed is in your Member Centre >> Connection details >> High speed broadband.

A link to a thinkbroadband speed test result, with the computer wired to the router would be a useful thing to see.

My broadband basic info/help site - www.robertos.me.uk. Domains, site and mail hosting - Tsohost.
Connection - Plusnet UnLim Fibre (FTTC). Sync 60000/16961kbps @ 600m. - IPv4BQM IPv6BQM
Standard User philippercival
(fountain of knowledge) Wed 03-Jun-15 23:26:32
Print Post

Re: G.INP and settings


[re: RobertoS] [link to this post]
 
Thank you for your response.

Test Result

From the Member centre:

Estimated line speed:
There's no speed estimate currently held on your account.
Current line speed:
58.6 Mb

So it looks like you are spot on,

Thanks for taking the time.

Edit: added From the performance tester:

1. Best Effort Test: -provides background information.

Download Speed
56.62 Mbps

0 Mbps 58.93 Mbps
Max Achievable Speed

Download speedachieved during the test was - 56.62 Mbps
For your connection, the acceptable range of speedsis 47.14 Mbps-58.93 Mbps .
Additional Information:
IP Profile for your line is - 58.93 Mbps

2. Upstream Test: -provides background information.

Upload Speed
15.33 Mbps

0 Mbps 20 Mbps
Max Achievable Speed

Upload speed achieved during the test was - 15.33Mbps
Additional Information:
Upstream Rate IP profile on your line is - 20 Mbps

http://speedtest.net/result/2459383290.png

Solar Results
2013 3521kwh,   2014 3435kwh, 2015  1540kwh (so far)
My Broadband Ping

Edited by philippercival (Wed 03-Jun-15 23:33:53)


Register (or login) on our website and you will not see this ad.

Standard User RobertoS
(elder) Wed 03-Jun-15 23:55:31
Print Post

Re: G.INP and settings


[re: philippercival] [link to this post]
 
That all looks pretty normal. You have probably just lost speed due to cross-talk since your initial connection. That may sort out if Openreach ever introduce vectoring.

Do you have a static IP address? Your sig-BQM gave me a bit of a scare with the packet loss, then I saw it was last year. If you don't have static it's worth the one-off £5 so your BQM always works. See the "Live link" in my sig. Just the IPv4 one, as I've lost my IPv6 connection at the moment.

My broadband basic info/help site - www.robertos.me.uk. Domains, site and mail hosting - Tsohost.
Connection - Plusnet UnLim Fibre (FTTC). Sync 60000/16961kbps @ 600m. - IPv4BQM IPv6BQM
Standard User philippercival
(fountain of knowledge) Thu 04-Jun-15 00:25:08
Print Post

Re: G.INP and settings *DELETED*


[re: RobertoS] [link to this post]
 
Post deleted by philippercival
Standard User philippercival
(fountain of knowledge) Thu 04-Jun-15 00:29:31
Print Post

Re: G.INP and settings


[re: RobertoS] [link to this post]
 
Yes I do have a fixed IP address.

I have updated the graph in my sig to today. However I did switch modems briefly after flashing the spare one, to see the stats.

http://speedtest.net/result/2459383290.png

Solar Results
2013 3521kwh,   2014 3435kwh, 2015  1540kwh (so far)

My Broadband Ping
Standard User RobertoS
(elder) Thu 04-Jun-15 00:43:18
Print Post

Re: G.INP and settings


[re: philippercival] [link to this post]
 
And got a slight drop in latency.

I had managed to get to your BQM by part-copying it into WordPad from your sig, then copying the actual link from that. I still can't work out what was wrong with it LOL. The link appeared to go past the ] and include the My. I couldn't work out how!

Edit - I've worked out why I was seeing it incorrectly. The part-copy was messed up by me.

My broadband basic info/help site - www.robertos.me.uk. Domains, site and mail hosting - Tsohost.
Connection - Plusnet UnLim Fibre (FTTC). Sync 60000/16961kbps @ 600m. - IPv4BQM IPv6BQM

Edited by RobertoS (Thu 04-Jun-15 00:44:44)

Standard User philippercival
(fountain of knowledge) Thu 04-Jun-15 09:14:39
Print Post

Re: G.INP and settings


[re: RobertoS] [link to this post]
 
I think the link is working now. I made a mistake in updating my sig, though I am not sure what, hence the deleted post above. I am hoping that you took your link from that (it appeared as text).

http://speedtest.net/result/2459383290.png

Solar Results
2013 3521kwh,   2014 3435kwh, 2015  1540kwh (so far)

My Broadband Ping
Standard User RobertoS
(elder) Thu 04-Jun-15 12:51:23
Print Post

Re: G.INP and settings


[re: philippercival] [link to this post]
 
Yes, the revised one works. Odd that neither of us could see anything wrong with it.

I expect it is still possible to accidentally include a "non-printing" character in your typing, which screws things up. Years ago it was a quite common but hard to diagnose problem.

As I said, I had managed to get the link from your bad sig. Note that you can test any sig change at the post Preview stage. And any in-post links. Correcting any errors then previewing again replaces the sig or link. You can't replace a sig in something already posted, though of course you can alter anything in the post body.

My broadband basic info/help site - www.robertos.me.uk. Domains, site and mail hosting - Tsohost.
Connection - Plusnet UnLim Fibre (FTTC). Sync 60000/16961kbps @ 600m. - IPv4BQM IPv6BQM

Edited by RobertoS (Thu 04-Jun-15 12:52:13)

  Print Thread

Jump to