General Discussion
  >> Fibre Broadband


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | 3 | 4 | (show all)   Print Thread
Standard User craski
(regular) Tue 26-Jan-16 09:39:15
Print Post

Openreach ECI Modem performance


[link to this post]
 
I recently replaced my Billion 8800 NL with the Openreach ECI modem to facilitate fault reporting of a congested line.

The Billion was syncing at 79999/19999 on an IP profile of 77.42Mbps
Minimum latency showing on BQM was around 22ms

The ECI modem is syncing at 72237/19999 on an IP profile of 69.92Mbps
Minimum latency is sitting around 30ms.

In summary, I've lost about 7Mb down speed and latency has increased by 8ms when using the ECI.

I have bought a second hand Huawei HG612 and unlocked it so the plan is to put that on the line at some point but I though I would give the ECI a chance before switching it out.

The ECI modem has been up and synced now for 13 days.

1. Is this as good as the ECI performance is likely to get or should I be more patient and give it a few more days to see if it reaches the same performance as the Billion?

2. If I fit the Billion or Huawei, will that over the course of time reset the IP profile applied?

Zen Unlimited Fibre Office BQM

Edited by craski (Tue 26-Jan-16 09:40:04)

Standard User BatBoy
(sensei) Tue 26-Jan-16 09:48:14
Print Post

Re: Openreach ECI Modem performance


[re: craski] [link to this post]
 
1. Yes. The problem here is the ECI doesn't support G.INP

2. Yes. As soon as G.INP turns on again, your line will resync at the max. Maybe 2 weeks
Standard User WWWombat
(knowledge is power) Tue 26-Jan-16 10:43:29
Print Post

Re: Openreach ECI Modem performance


[re: craski] [link to this post]
 
1. Did you have upstream G.INP activated with the Billion?

2. Has the ECI been connected long enough to get the most recent firmware update? What firmware is it running?

In the bad old days, the ECI (like the HH5A) couldn't cope with G.INP activation - and the end result was that the sync speed reduced and the latency increased. But there seemed to be a couple of different problems - the use of G.INP upstream, and firmware problems.

Openreach changed DLM to not activate G.INP upstream by default, and the HH5A received new firmware. The ECI, though, is rather harder to figure - but if there is a firmware update, you need to be plugged in for a while to be updated. You'd think 13 days was enough.

Loads more detail at Kitz...
http://forum.kitz.co.uk/index.php/topic,15283.msg284...

Putting the HG612 on should fix things in a very short order.


Register (or login) on our website and you will not see this ad.

Standard User craski
(regular) Tue 26-Jan-16 11:34:03
Print Post

Re: Openreach ECI Modem performance


[re: WWWombat] [link to this post]
 
I'll check back on my logs/screengrabs to see what the G.INP status was on the Billion prior to swapping it for the ECI.

From the link on Kitz, I've had both issues listed with the ECI. The first one 24 hrs after installing it, it hung and wouldnt connect to internet despite the sync light being on. Following a reboot, thats when the latency increased and sync speeds dropped. It hasnt re-synced since and its been up for 13 days now.

I think I will stick the HG612 on, at least then I can see the stats and tell what is going on, the lack of any info from the ECI is frustrating.

Is it even possible to find out what firmware the ECI is running without taking it offline?

Zen Unlimited Fibre Office BQM
Standard User BatBoy
(sensei) Tue 26-Jan-16 11:55:39
Print Post

Re: Openreach ECI Modem performance


[re: craski] [link to this post]
 
In reply to a post by craski:
I've had both issues listed with the ECI. The first one 24 hrs after installing it, it hung and wouldnt connect to internet despite the sync light being on.
This is due to G.INP being enabled which the ECI doesn't support
Following a reboot, thats when the latency increased and sync speeds dropped. It hasnt re-synced since and its been up for 13 days now.
This means that G.INP has gone off - all IMO of course.
Standard User craski
(regular) Tue 26-Jan-16 13:37:48
Print Post

Re: Openreach ECI Modem performance


[re: BatBoy] [link to this post]
 
I just swapped out the ECI for the Huawei.

Noticed an immediate increase in sync to 77375 down.

Now I can see stats, i can see that for ECI, G.INP was not enabled and interleave depth on downstream is currently 1515 and 1 on upstream.

Is interleave depth of 1515 bad?

Zen Unlimited Fibre Office BQM
Standard User BatBoy
(sensei) Tue 26-Jan-16 13:44:19
Print Post

Re: Openreach ECI Modem performance


[re: craski] [link to this post]
 
Yes quite bad. It doesn't sound like G.INP is on yet.
Standard User WWWombat
(knowledge is power) Tue 26-Jan-16 14:05:44
Print Post

Re: Openreach ECI Modem performance


[re: craski] [link to this post]
 
An interleaving depth that is in the hundreds or thousands tells us DLM has intervened old-style, with relatively aggressive FEC and interleaving without retransmission.

However, you really need to quote more of the line stats to tell just how aggressive; DLM used to set INP=3, delay=8 for "low interleaving" and INP=4, delay=16 for "high interleaving", and other values if upstream intervention has happened too.

I've seen a couple of recent examples that suggest DLM intervention nowadays might come with different settings.

The set of parameters that show the modem's reaction are found in R, D, I and N - not just the depth. They will help work out the FEC overhead too.
Standard User craski
(regular) Tue 26-Jan-16 14:19:32
Print Post

Re: Openreach ECI Modem performance


[re: WWWombat] [link to this post]
 
Here is the whole lot from DSLstats...

xdslcmd info --stats
xdslcmd: ADSL driver and PHY status
Status: Showtime
Retrain Reason: 0
Last initialization procedure status: 0
Max: Upstream rate = 33956 Kbps, Downstream rate = 89688 Kbps
Bearer: 0, Upstream rate = 19999 Kbps, Downstream rate = 77375 Kbps

Link Power State: L0
Mode: VDSL2 Annex B
VDSL2 Profile: Profile 17a
TPS-TC: PTM Mode(0x0)
Trellis: U:ON /D:ON
Line Status: No Defect
Training Status: Showtime
Down Up
SNR (dB): 6.1 15.7
Attn(dB): 13.9 0.0
Pwr(dBm): 13.7 3.9
VDSL2 framing
Bearer 0
MSGc: 18 26
B: 51 237
M: 1 1
T: 64 42
R: 12 16
S: 0.0214 0.3781
L: 23944 5374
D: 1515 1
I: 64 127
N: 64 254
Counters
Bearer 0
OHF: 3073787 1064097
OHFErr: 0 0
RS: 786704812 1722649
RSCorr: 2133 0
RSUnCorr: 0 0

Bearer 0
HEC: 0 0
OCD: 0 0
LCD: 0 0
Total Cells: 628278360 0
Data Cells: 7049185 0
Drop Cells: 0
Bit Errors: 0 0

ES: 0 0
SES: 0 0
UAS: 90 90
AS: 4224

Bearer 0
INP: 3.00 0.00
INPRein: 0.00 0.00
delay: 8 0
PER: 1.37 3.98
OR: 139.75 64.22
AgR: 77515.20 20063.54

Bitswap: 3054/3054 0/0

Total time = 1 hours 11 min 54 sec
FEC: 2133 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 90 90
LOS: 0 0
LOF: 0 0
LOM: 0 0
Latest 15 minutes time = 11 min 54 sec
FEC: 186 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0
Previous 15 minutes time = 15 min 0 sec
FEC: 27 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0
Latest 1 day time = 1 hours 11 min 54 sec
FEC: 2133 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 90 90
LOS: 0 0
LOF: 0 0
LOM: 0 0
Previous 1 day time = 0 sec
FEC: 0 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0
Since Link time = 1 hours 10 min 23 sec
FEC: 2133 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0
#

Zen Unlimited Fibre Office BQM
Standard User RobertoS
(elder) Tue 26-Jan-16 14:41:32
Print Post

Re: Openreach ECI Modem performance


[re: craski] [link to this post]
 
Assuming you have the latest unlocked firmware/software, (V100R001C01B030SP08 easily seen if you go in through the GUI), then also assuming G.INP is implemented on your cabinet in a few days it will probably be turned on for your line.

If that happens your sync will go up and you will also get data for Bearer 1.

The indispensable man or woman passes from the scene, and what happens next is more or less the same thing as was happening before.
My broadband basic info/help site - www.robertos.me.uk. Domains, site and mail hosting - Tsohost.
Connection - AAISP Home::1 80/20. Sync 59997/15142kbps @ 600m. - BQM
Pages in this thread: 1 | 2 | 3 | 4 | (show all)   Print Thread

Jump to