General Discussion
  >> Fibre Broadband


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | 3 | (show all)   Print Thread
Standard User MarkOSSL
(newbie) Thu 04-Jan-18 20:18:03
Print Post

Draytek Vigor 2850 Speed Problem


[link to this post]
 
Hi,
Not sure if this is the right forum but : -

I have a 80/20 mbps broadband connection. When I do a speed test, I consistently only get 45 mbps downstream. This is tested over several days.

The problem occurs if I use the Draytek as the modem, or if I use the BT Openreach as the modem, and the Draytek just as a router. The sync speed is fine (79812). And yes it is consistently fine, no dropouts. This has been confirmed by my ISP after days of monitoring.

If I swap the 2850 out for my cheapo TP-Link router, I get FULL speed (typically 75 mbps).... Again, consistently.

I've tried re-flashing the latest firmware and a full factory reset, but no difference.

I'm on the verge of shelling out for a new router, because this just does not make sense. How can my cheap router outperform my Draytek speed-wise?

Don't know if anyone has any experience of Draytek..

Thanks!
Mark.
Standard User caffn8me
(eat-sleep-adslguide) Thu 04-Jan-18 20:38:29
Print Post

Re: Draytek Vigor 2850 Speed Problem


[re: MarkOSSL] [link to this post]
 
There's one more test you should do. You can plug your computer directly into the Openreach modem and set up a PPPoE connection and test using that.

I think that's the first thing you need to do as this will eliminate the Draytek as a source of the problem. I'd be very surprised if the Draytek was limiting you as I've use the 2850 for several years on FTTC without any issues.

Who is your ISP?

Sarah

--
If I can't drink my bowl of coffee three times daily, then in my torment, I will shrivel up like a piece of roast goat

Spiders on coffee - Badass spiders on drugs
Standard User ian007jen
(experienced) Thu 04-Jan-18 20:50:36
Print Post

Re: Draytek Vigor 2850 Speed Problem


[re: MarkOSSL] [link to this post]
 
wirerd or wireless?


Register (or login) on our website and you will not see this ad.

Standard User MarkOSSL
(newbie) Thu 04-Jan-18 22:14:48
Print Post

Re: Draytek Vigor 2850 Speed Problem


[re: ian007jen] [link to this post]
 
Wired, cat 7.
Standard User MarkOSSL
(newbie) Thu 04-Jan-18 22:21:22
Print Post

Re: Draytek Vigor 2850 Speed Problem


[re: caffn8me] [link to this post]
 
My ISP is Zen Internet.

The thing to remember is, I've substituted another router *directly* in place of the Draytek. If the Openreach modem or line was at fault, the substitute router would also exhibit the problem.

The substitute router is a cheap TP-Link £35 router.... and the speed test sits beautifully at around 75mbps hardly wavering.

I'm at a loss. I generally know what I'm doing with all this; I've been a freelance software engineer for nearly 18 years, and I've written firmware in C for proprietary tracking devices (which was a challenge back in 2003!). Just trying to get across that generally when it comes to technical stuff and testing, I know what I'm doing.. I hope wink

But I still can't make a Draytek router work at full speed wink
Standard User ian007jen
(experienced) Thu 04-Jan-18 22:24:28
Print Post

Re: Draytek Vigor 2850 Speed Problem


[re: MarkOSSL] [link to this post]
 
any QOS, try a full factory reset; after testing the PPPoE connection with PC/MAC.
Standard User MarkOSSL
(newbie) Thu 04-Jan-18 23:11:59
Print Post

Re: Draytek Vigor 2850 Speed Problem


[re: ian007jen] [link to this post]
 
QoS all off, done factory reset several times and started from scratch.. no change frown
Standard User MarkOSSL
(newbie) Fri 05-Jan-18 02:46:10
Print Post

Re: Draytek Vigor 2850 Speed Problem


[re: MarkOSSL] [link to this post]
 
I may have found my answer.

Looking at the chart in the link below : -

http://www.draytek.co.uk/support/5

It seems to say the maximum NAT session throughput is 50Mb/s - assuming that is megabits and not megabytes...

Edited by MarkOSSL (Fri 05-Jan-18 08:49:11)

Standard User Zarjaz
(eat-sleep-adslguide) Fri 05-Jan-18 05:42:36
Print Post

Re: Draytek Vigor 2850 Speed Problem


[re: MarkOSSL] [link to this post]
 
You omitted the link in your post ?

Standard User aquiss
(fountain of knowledge) Fri 05-Jan-18 08:33:34
Print Post

Re: Draytek Vigor 2850 Speed Problem


[re: MarkOSSL] [link to this post]
 
This has been a known bug for a while, that we have seen on 2850s for some time.

Basically from what I recall with ours and clients, it's something to do with QoS that limits the speeds, even when off. You need to enable it, increase the max throughput, save and then it should be ok. Even turning QoS at that point seems to maintain the throughput.

We reported this to Draytek 2 years ago, but they never seemed to be bothered to fix it. They released the 2860 less than 6 months after 2850 was launched.

Martin Pitt
Aquiss Limited
http://www.aquiss.net

Unlimited Family Broadband Packages : http://www.aquiss.net/broadband-unlimited.php
Pages in this thread: 1 | 2 | 3 | (show all)   Print Thread

Jump to