Technical Discussion
  >> Linux Issues


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | 3 | 4 | (show all)   Print Thread
Standard User mrdigital03
(newbie) Mon 24-Dec-12 14:13:56
Print Post

Broadcom wireless driver detects other routers except mine.


[link to this post]
 
I am writing regarding the Broadcom 4227 wireless receiver that I have on my Acer 5755G laptop.

I have recently tried installing Lubuntu 12.10 but the wireless was not working. So I installed the pre-compliled driver that ubuntu provided. It started working after that but it does not detect my router for some reason (I can still detect neighbouring wireless networks). On windows 7, I am perfectly able to connect my router with this laptop.

To resolve this problem, I have installed both the drivers that are available: 1. STA (Broadcom proprietary) 2. Open source driver but both have not been successful in detecting the router. (But wireless does work!)

For installing and diagnosing the STA driver, I have followed the information provided at ( http://www.broadcom.com/support/802.11/linux_sta.php ) even that did not help.

I cannot give much information on the router as I do not have admin access to the router settings. Additionally, I don't know if this would be useful; In order to update my repositories, I did manage to connect to this router via my android phone via tethering. Thinking this might be affecting somehow, I have even tried deleting the settings of this wired connection but even that did not prove any useful.

Any help on this matter would be much appreciated.
Standard User Uilebheist
(legend) Mon 24-Dec-12 14:40:09
Print Post

Re: Broadcom wireless driver detects other routers except mi


[re: mrdigital03] [link to this post]
 
Well, it may be useful to know where in the process it stops working.
In a terminal try typing the following two commands:

sudo iwconfig wlan0
sudo ifconfig wlan0

The first one should show the router's SSID and MAC address - if it says "not associated" then it didn't even get that far.
If it associates the second line will tell you whether it managed to get and IP address via DHCP.

What router model is it (in case it makes any difference).

For example, I have

iwconfig wlan0:
wlan0     IEEE 802.11bgn  ESSID:"not telling"  
          Mode:Managed  Frequency:2.472 GHz  Access Point: 00:xx:xx:xx:xx:xx:xx
...
ifconfig wlan0:
wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.xxx.xxx  netmask 255.255.255.0  broadcast 192.168.xxx.255

But with the wireless off:
iwconfig wlan0:
wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Frequency:2.472 GHz  Access Point: Not-Associated   
...
ifconfig wlan0:
wlan0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:xx:xx:xx:xx:xx  txqueuelen 1000  (Ethernet)
Standard User mrdigital03
(newbie) Mon 24-Dec-12 16:02:48
Print Post

Re: Broadcom wireless driver detects other routers except mi


[re: Uilebheist] [link to this post]
 
IWCONFIG AND IFCONFIG do not display much as the card is not connected to the router.

it does not show any ESSID or any other related info as they are not connected.

I dont know if this helps, but my wireless card has strangely associated itself with eth1 instead of wlan0


Register (or login) on our website and you will not see this ad.

Standard User Uilebheist
(legend) Mon 24-Dec-12 16:47:32
Print Post

Re: Broadcom wireless driver detects other routers except mi


[re: mrdigital03] [link to this post]
 
Well, the actual name may be changed by udev rules - I suppose ubuntu decided to rename all the wlan to eth for whatever reason. Doesn't necessarily mean anything.
I assume you re-entered any password just to rule out typos etc.
The other thing to do is to check the output of the "dmesg" command to see if there's any error message mentioning wlan0, eth1 or broadcom.
Standard User yarwell
(sensei) Mon 24-Dec-12 16:48:06
Print Post

Re: Broadcom wireless driver detects other routers except mi


[re: mrdigital03] [link to this post]
 
what channel is the access point on ? your phone should say in settings, or install a WiFi analyzer app.

I ask because some wireless setups can't see above channel 11 as they're set up for the USofA, so an AP on ch13 becomes invisible

--

Phil

MaxDSL - goes as fast as it can and doesn't read the line checker first.

MaxDSL diagnostics
Standard User Uilebheist
(legend) Mon 24-Dec-12 17:02:45
Print Post

Re: Broadcom wireless driver detects other routers except mi


[re: yarwell] [link to this post]
 
Good point - although Ubuntu should have loaded the appropriate regulatory data once it has determined the locality - I use different distros, but they are all able to use channels > 11 (and we know the adapter itself can do it as the wireless works in Windows).
It may be useful to see if the ESSID appears in the list of networks at all - I'm sure the Ubuntu network manager has a way to display that, otherwise the command "sudo iwlist eth1 scan" will show this information, including channel used etc for all networks it detects.
Standard User mrdigital03
(newbie) Mon 24-Dec-12 17:57:22
Print Post

Re: Broadcom wireless driver detects other routers except mi


[re: Uilebheist] [link to this post]
 
output of IWCONFIG:

lubuntu@lubuntu:~$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11 Access Point: Not-Associated
Link Quality:5 Signal level:0 Noise level:213
Rx invalid nwid:0 invalid crypt:0 invalid misc:0

usb0 no wireless extensions.
----------------------------------------------------------------------
*note: USB0 is the tethered connection to my android phone
--------------------------------------------------------------------------

output of IFCONFIG:

eth0 Link encap:Ethernet HWaddr dc:0e:a1:12:57:e0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:16

eth1 Link encap:Ethernet HWaddr 60:d8:19:16:da:81
inet6 addr: fe80::62d8:19ff:fe16:da81/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:673 errors:0 dropped:0 overruns:0 frame:0
TX packets:673 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:56453 (56.4 KB) TX bytes:56453 (56.4 KB)

usb0 Link encap:Ethernet HWaddr a6:f6:d7:d9:a3:14
inet addr:192.168.42.197 Bcast:192.168.42.255 Mask:255.255.255.0
inet6 addr: fe80::a4f6:d7ff:fed9:a314/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7971 errors:0 dropped:0 overruns:0 frame:0
TX packets:5786 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9431597 (9.4 MB) TX bytes:1203010 (1.2 MB)
Standard User mrdigital03
(newbie) Mon 24-Dec-12 18:01:16
Print Post

Re: Broadcom wireless driver detects other routers except mi


[re: Uilebheist] [link to this post]
 
Output of DMESG:

http://pastebin.com/M6uQtH0v
Standard User mrdigital03
(newbie) Mon 24-Dec-12 18:06:45
Print Post

Re: Broadcom wireless driver detects other routers except mi


[re: yarwell] [link to this post]
 
Channel 13 2472MHz

Even I had thought of this before but 2.4GHz is a very common spectrum being used for a very long time. So it should not be a problem. I would have probably considered this if it was above 5GHz range.

Also if the channel is reduced to a lower level, it results in wireless drop out issues on the other devices.

Surely this is more to do with on the driver side rather than router side
Standard User Uilebheist
(legend) Mon 24-Dec-12 18:09:38
Print Post

Re: Broadcom wireless driver detects other routers except mi


[re: mrdigital03] [link to this post]
 
Looking at dmesg, you are using the "world" regulatory domain i.e. only frequencies which are legal to use everywhere. So as yarwell suggests it may well be that you can't see the router because it is using a channel higher than 11.
I have no idea how to change that in the Ubuntu network manager or whatever, but you can try the following command:
sudo iw reg set GB
if wireless starts working after that, you just have to figure out how to make it permanent i.e. not be cleared on reboot.

edit - I see you posted while I was typing and you are using channel 13, which would be invisible given the settings.

Edited by Uilebheist (Mon 24-Dec-12 18:10:45)

Pages in this thread: 1 | 2 | 3 | 4 | (show all)   Print Thread

Jump to