Technical Discussion
  >> Home Networking, Internet Connection Sharing, etc.


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User colic
(fountain of knowledge) Fri 13-Jul-12 09:37:04
Print Post

Belkin F5D8635-4 V1 Firewall


[link to this post]
 
I have bought the aboved mentioned router and am having no end of problems with it and I am just after some general advice.

Setting up to work on my PC, laptop and iphone all worked fine. The ps3 will not connect to is and even some PC programs refuse to work with it.

The main program I need to use is filezilla or crossftp both of which are very similar they just connect to my website.

I have read all about port forwarding here

http://portforward.com/english/routers/port_forwardi...

Everything is set up exactly the same but they both refuse to connect to my servers.

I thought then if I disabled the firewall then it would connect to my server, nope just the message

Error: Connection timed out
Error: Failed to retrieve directory listing

I know that the servers are online and working as I can connect to them using the same programs using my 3 mobile dongle!

When I test the ports with an online checker it stats that port 21 is blocked even if I turn the firewall off (not sure if this makes a difference)

Any help would be much appreciated as I have spent about 3 hours on google now and got no where frown
Standard User prlzx
(committed) Sat 14-Jul-12 13:35:49
Print Post

Re: Belkin F5D8635-4 V1 Firewall


[re: colic] [link to this post]
 
re the PS3

Is it trying to connect by wireless or wired?
If wireless try turning off encryption (temporary) until you can confirm the PS3 can connect by wireless at all, so you can tell if there is something it doesn't like about the encryption.

As the iphone is connecting ok (and if getting online) we can assume the setup including wireless is not inherently broken.

re FTP

If your FTP servers are on the internet, you won't normally need any port forwarding on your router firewall to connect to them from your local network. Port 21 only needs to be open at the server end, not forwarded on your router.

In a reasonably current version of FileZilla (client) settings try choosing "Passive Mode" (with option to fallback to "Active mode"). This means both the control and data connections will be initiated at your end (which is more likely to work when you are behind NAT).

With "Active Mode" you may find you can initially connect and supply username / password but can't see a directory listing or transfer files. The server tries to open the data connection back to you and it connects from source port 20 to a destination port chosen randomly from a dynamic range.

Unfortunately this means you can't just forward destination port 20 because this isn't what it is doing. And most home routers don't allow you to specify source ports at all, only the external destination port as it arrives at the firewall and the internal destination port to forward to.

In this case your router has to watch the FTP control traffic for the port numbers and allow this related connection through - otherwise known as an Application Layer Gateway (ALG) for FTP. Some routers have these features built-in and enabled automatically (may not even be mentioned in the user interface) certainly my old Netgear allows this and there is no UI setting for it.

If you are using Windows (anything since XP SP2) I expect Windows Firewall will have popped up originally the first time FileZilla connected to an FTP server and if you allowed that program to receive connections at that point it will still be ok. For any other 3rd party firewall software you will need to check it's on some kind of "allowed programs" list but as it is working via a 3G connection again this part already seems to be setup right.



prompt $P - Invalid drive specification - Abort, Retry, Fail? $G
prlzx on n e w n e t: ADSL2+ / 21CN at 3.5Mbps / 800kbps
Standard User colic
(fountain of knowledge) Tue 17-Jul-12 19:37:18
Print Post

Re: Belkin F5D8635-4 V1 Firewall


[re: prlzx] [link to this post]
 
Thanks for that I changed the settings to passive mode and all worked fine smile

I have tried the PS3 without encryption and with. I followed a guide from Belkin themselves to the letter but I still dont have it working :/

It does connect for about 30 seconds and then I get a PS3 error message saying the connection is lost.

I think I am just going to move the router and have it wired to the PS3!


Register (or login) on our website and you will not see this ad.

  Print Thread

Jump to