Technical Discussion
  >> Home Networking, Internet Connection Sharing, etc.


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User Timalay
(experienced) Mon 03-Mar-14 21:42:42
Print Post

TP-Link Router wireless problem


[link to this post]
 
I recently purchased a new TP-Link Archer C7 to replace my Plusnet fibre router (technicolor tg582n). It seems very slow streaming wirelessly via my laptop, TV and Xbox 360.
Anything that might help it. Should I using a specific wifi channel.
Administrator MrSaffron
(staff) Tue 04-Mar-14 09:51:44
Print Post

Re: TP-Link Router wireless problem


[re: Timalay] [link to this post]
 
Is it just streaming? Are downloads working to the speeds you expect? If it is internet streaming how do the two download tests from http://www.thinkbroadband.com/speedtest.html look like

If in an urban area with lots of other wifi users then if using 2.4GHz the only answer may be to move to 5GHz

Andrew Ferguson, andrew@thinkbroadband.com
www.thinkbroadband.com - formerly known as ADSLguide.org.uk
The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
Standard User Timalay
(experienced) Tue 04-Mar-14 19:30:37
Print Post

Re: TP-Link Router wireless problem


[re: MrSaffron] [link to this post]
 
It's not just WiFi it seems, it seems to be like this on the computer connected to directly to the router. Also it only shows the 2.4ghz band on my laptop and xbox 360 (TV next to xbox 360 can get 5ghz).

Edited by Timalay (Tue 04-Mar-14 19:32:34)


Register (or login) on our website and you will not see this ad.

Administrator MrSaffron
(staff) Tue 04-Mar-14 21:56:11
Print Post

Re: TP-Link Router wireless problem


[re: Timalay] [link to this post]
 
So what do you get from the speed test

Andrew Ferguson, andrew@thinkbroadband.com
www.thinkbroadband.com - formerly known as ADSLguide.org.uk
The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
Standard User Timalay
(experienced) Tue 04-Mar-14 22:14:29
Print Post

Re: TP-Link Router wireless problem


[re: MrSaffron] [link to this post]
 
Basically from say Thinkbroadband speed test. It tests the the down load fine, but seems to hang on testing the upload.
Administrator MrSaffron
(staff) Tue 04-Mar-14 23:35:51
Print Post

Re: TP-Link Router wireless problem


[re: Timalay] [link to this post]
 
Well that is not normal

Try this version http://labs.thinkbroadband.com/ispa

Andrew Ferguson, andrew@thinkbroadband.com
www.thinkbroadband.com - formerly known as ADSLguide.org.uk
The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
Standard User Amjad
(newbie) Wed 05-Mar-14 01:35:55
Print Post

Re: TP-Link Router wireless problem


[re: MrSaffron] [link to this post]
 
This router has a lot of stability and performance issues with WiFi with the current firmware. Both radio bands are affected, 5GHz is especially bad.

TP-Link Germany have a beta firmware which resolves most of the issues, it's not 100% yet though. You may still have to restart the router every few days to resolve slow speeds.

TP-Link Archer C7 v1 beta firmware.
Standard User Timalay
(experienced) Wed 05-Mar-14 18:26:46
Print Post

Re: TP-Link Router wireless problem


[re: MrSaffron] [link to this post]
 
That seems to work yet.
  Print Thread

Jump to