Technical Discussion
  >> Home Networking, Internet Connection Sharing, etc.


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User GeoffB
(fountain of knowledge) Fri 05-Sep-14 09:03:13
Print Post

Cannot connect all network devices?


[link to this post]
 
My Epson SX535WD printer will not connect to my network if it is not the first device switched on before the computers. So if we forget and switch on a laptop first followed by the Epson, it refuses to print. If the printer is on first, no trouble. I'm using Ethernet cables at the moment via a Netgear switch but we had the same issue when we used wireless. Annoying rather than a big issue, but I'd be interested in a solution. I'd like the printer to be able to join the network whenever it's powered up in relation to the other devices.

Dell Studio1558 with Win7 Home Premium
8GB RAM
HP Pavilion netbook Win8 8GB RAM
IE11 and Live Mail
BT Infinity via HH3
(Virgin 150Mbs as backup)
Standard User panda
(committed) Fri 05-Sep-14 09:07:39
Print Post

Re: Cannot connect all network devices?


[re: GeoffB] [link to this post]
 
Does the printer have a static address?

Eats shoots and leaves.
Standard User GeoffB
(fountain of knowledge) Fri 05-Sep-14 13:17:39
Print Post

Re: Cannot connect all network devices?


[re: panda] [link to this post]
 
It's assigned by DHCP when it connects. Could that be the problem?

Dell Studio1558 with Win7 Home Premium
8GB RAM
HP Pavilion netbook Win8 8GB RAM
IE11 and Live Mail
BT Infinity via HH3
(Virgin 150Mbs as backup)


Register (or login) on our website and you will not see this ad.

Standard User ukhardy07
(knowledge is power) Fri 05-Sep-14 14:16:43
Print Post

Re: Cannot connect all network devices?


[re: GeoffB] [link to this post]
 
How did you setup the printer, did you use the software provided with the printer CD? I am thinking you didn't and installed it using the windows configuration utility.

Basically if you set it up this way then windows will only look for your printer at a specific IP address. So if it's the first device enabled it's likely to be something along the lines of 192.168.0.2

2nd device, it will be 192.168.0.3 - then windows will not recognise it.

Setting the printer to a static IP of 192.168.0.2 isn't a solution either.... This is because DHCP will allocate the first device connected as 192.168.0.2 - say a laptop is the first connected this gets that IP
Then turning on the printer, it will ALSO try to use 192.168.0.2 causing an IP conflict

A solution is to reset up the printer using the provided software following it through step by step OR set the printer to a really high IP such as 192.168.0.150 (then no conflict unless 149 devices connect). You'd have to reinstall the printer though to get it to register at this new IP (but you could use the windows way of installing rather than CD).
Standard User panda
(committed) Fri 05-Sep-14 14:57:19
Print Post

Re: Cannot connect all network devices?


[re: GeoffB] [link to this post]
 
It may be if it's given a different IP address, as your devices may be looking for the original address that was issued to the printer when you first setup.

If you're using a HH3, I think (I've only used a Business Hub 3, so there may be differences) you can set the router to assign the same address to the printer every time (so 'pseudo' static) via DHCP.
Have a look in Advanced Settings -> Network -> Devices

You should be able to click on the printer and then select an option 'Always use this IP address' which will reserve and use the current assigned address for the printer only.

Eats shoots and leaves.
Standard User XRaySpeX
(eat-sleep-adslguide) Fri 05-Sep-14 17:30:22
Print Post

Re: Cannot connect all network devices?


[re: ukhardy07] [link to this post]
 
In reply to a post by ukhardy07:
Setting the printer to a static IP of 192.168.0.2 isn't a solution either.... This is because DHCP will allocate the first device connected as 192.168.0.2
Not if you arrange the DHCP range so that 192.168.0.2 is outside, which is the obvious thing to do.

Some routers also allow you to reserve an IP within the DHCP range for specific devices.

1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC
  Print Thread

Jump to