Technical Discussion
  >> Home Networking, Internet Connection Sharing, etc.


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | 3 | (show all)   Print Thread
Standard User Kotek_Besar
(newbie) Tue 12-Apr-16 14:44:45
Print Post

Sky fibre / HG612 / R7000 - no connection


[link to this post]
 
Hi folks, I'm new here. laugh

So I have the following:

BTO Huawei HG612 modem.
Netgear R7000 on DD-WRT v24-sp2 (04/16/14) kongac.
Sky fibre unlimited.

Today is my Sky active line takeover day. I was previously on BT fibre and it worked fine with my current setup. When I was with BT, I had to make the connection in the router settings by selecting Connection Type: PPPoE and using bthomehub@btbroadband.com and bt as the password.

Now I have Sky fibre, I read online that I have to select Conenction Type: Automatic Configuration - DHCP, make sure that Use DNSMasq for DHCP and Use DNSMasq for DNS are both ticked, and then go in to Administration, Commands and use

Text
1
2
killall udhcpc 
udhcpc -i vlan2 -x 0x3d:XXXXXXXXXXXXXXXXXXXXXXXXXXXX -p /var/run/udhcpc.pid -s /tmp/udhcpc &

Save statup. (XXXXXXXXXXXXXXXXXXXXXXXXXXXX = a1b2c3d4e5f6@skydsl|abcd1234 converted to hex).

and..
Text
1
iptables -I INPUT -p udp --sport 67 --dport 68 -j ACCEPT

Save firewall.

Long story short - it just doesn't connect. I don't know what's going on. If I connect my laptop via ethernet to LAN2 on the HG612 and log in to the setting page, I can see it's connected to the DSL line at around 58000 kbps.

What am I doing wrong?
Standard User BatBoy
(sensei) Tue 12-Apr-16 15:59:39
Print Post

Re: Sky fibre / HG612 / R7000 - no connection


[re: Kotek_Besar] [link to this post]
 
In reply to a post by Kotek_Besar:
What am I doing wrong?
Maybe you got the username and password wrong.
Maybe you did the hex convert wrong.
Maybe you did the DD-WRT settings wrong

There's a walkthrough here https://charleswilkinson.co.uk/2014/10/27/sky-fibre-...

If you have a Sky SR102 router, plug any lan port into LAN1 on the HG612 and see it that works.
Standard User Kotek_Besar
(newbie) Tue 12-Apr-16 16:06:00
Print Post

Re: Sky fibre / HG612 / R7000 - no connection


[re: BatBoy] [link to this post]
 
Thanks, but that's the guide I've been following. Simply doesn't work. I've double checked everything (username/pass/hex convert) three or four times - definitely not mistakes. SR102 connects fine.


Register (or login) on our website and you will not see this ad.

Standard User BatBoy
(sensei) Tue 12-Apr-16 16:12:28
Print Post

Re: Sky fibre / HG612 / R7000 - no connection


[re: Kotek_Besar] [link to this post]
 
Does the SR102 connect fine though the HG612?

There's another way to get your sky username and password here http://www.skyuser.co.uk/forum/extracting-sky-router...
Standard User ukhardy07
(knowledge is power) Tue 12-Apr-16 18:54:14
Print Post

Re: Sky fibre / HG612 / R7000 - no connection


[re: Kotek_Besar] [link to this post]
 
Did you already connect with your SR102 (sky hub). This is very important, when you switch to a new router / device on Sky, it takes approximately 2 hours before the network releases the old one and allows the new one.

This is due to Skys lease renewal interval for the external IP address of the old router.

It could all be setup fine, but you need to await that release.

Edited by ukhardy07 (Tue 12-Apr-16 18:54:29)

Standard User Kotek_Besar
(newbie) Tue 12-Apr-16 19:15:09
Print Post

Re: Sky fibre / HG612 / R7000 - no connection


[re: ukhardy07] [link to this post]
 
In reply to a post by ukhardy07:
Did you already connect with your SR102 (sky hub). This is very important, when you switch to a new router / device on Sky, it takes approximately 2 hours before the network releases the old one and allows the new one.

This is due to Skys lease renewal interval for the external IP address of the old router.

It could all be setup fine, but you need to await that release.

Thanks, that's helpful. I'm not sure if that is the issue or not though. You see, before I opened the new SR102 for this line, I initially tried to connect straightaway (after switchover from BT to Sky) with my DD-WRT / HG612 setup that was already in situ and in use with BT fibre, using the username and password from another SR102 that I own (and is currently in use with a Sky ADSL service on another line in the same property). When it didn't work, I wondered if it might be due to the fact that the username and password was already in use / not for this line.

So I opened the new SR102 that has been provided to me for use on this Sky fibre line, set it up, connected and retrieved the username and password with Wireshark. I then disconnected it, put it away and re-setup my DD-WRT / HG612 rig and re-configured it with the new username and password (well, the hex conversion of same).

Still, do you think your suggestion explains my issue?
Standard User ukhardy07
(knowledge is power) Tue 12-Apr-16 20:37:57
Print Post

Re: Sky fibre / HG612 / R7000 - no connection


[re: Kotek_Besar] [link to this post]
 
Are you using DHCP Option 61?

Also have you cloned the Sky router MAC, else you will likely need to wait?

Edited by ukhardy07 (Tue 12-Apr-16 20:45:16)

Standard User Kotek_Besar
(newbie) Tue 12-Apr-16 20:42:06
Print Post

Re: Sky fibre / HG612 / R7000 - no connection


[re: ukhardy07] [link to this post]
 
In reply to a post by ukhardy07:
Are you using DHCP Option 61?

Not sure. How can I check this?
Standard User ukhardy07
(knowledge is power) Tue 12-Apr-16 20:51:26
Print Post

Re: Sky fibre / HG612 / R7000 - no connection


[re: Kotek_Besar] [link to this post]
 
Sky is very unique in the way their Fibre works.

There is a good guide here and I can confirm I got it working on DD-WRT. Any questions I can try to help out. It has been 1.5 years since I did this myself though!

https://charleswilkinson.co.uk/2014/10/27/sky-fibre-...

I would go back to a fresh setup and set everything up as per the guide.

Edited by ukhardy07 (Tue 12-Apr-16 20:52:12)

Standard User Kotek_Besar
(newbie) Tue 12-Apr-16 20:53:39
Print Post

Re: Sky fibre / HG612 / R7000 - no connection


[re: ukhardy07] [link to this post]
 
In reply to a post by ukhardy07:
Sky is very unique in the way their Fibre works.

There is a good guide here and I can confirm I got it working on DD-WRT. Any questions I can try to help out. It has been 1.5 years since I did this myself though!

https://charleswilkinson.co.uk/2014/10/27/sky-fibre-...

I would go back to a fresh setup and set everything up as per the guide.


That's the guide I followed, and to the letter. Went over it several times to ensure I hadn't missed anything. It's bizarre. I think I'm going to hard reset the router and start from scratch.
Pages in this thread: 1 | 2 | 3 | (show all)   Print Thread

Jump to