User comments on ISPs
  >> Post Office


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User entslee
(newbie) Thu 17-Nov-16 13:51:24
Print Post

Post Office Broadband Never Works


[link to this post]
 
I arranged for my parents to get Post Office broadband installed in December 2015, when it was first installed it dropped out here and there but wasn't too bad, gradually over time it has got worse and worse, we are now lucky if it comes on and stays on for 30 minutes a day. When it is working it's great but it very rarely works. We have phoned the Post Office help line many many times and go through the same list of possible solutions / checks every time, try the test socket, change the filters etc. Basically my parents are paying for a product that doesn't work but the post office don't seem interested in doing anything about it. They did suggest paying to get an engineer sent out but even then there was no guarantee that they could sort the problem. This is driving me mad, can anyone please help?
Administrator MrSaffron
(staff) Thu 17-Nov-16 19:12:17
Print Post

Re: Post Office Broadband Never Works


[re: entslee] [link to this post]
 
Can you get the ADSL statistics from the modem?

They will give a very good idea of the lines performance, and then we can school you on what to watch out for to see if its the line going bad, or just very slow speeds from the Post Office service (some have complained of slow speeds in the past with the ADSL staying connected).

Also what exchange does https://labs.thinkbroadband.com/local/index.php?tab=3 say you are connected to, in some cases once we know that the best advice may be leave Post Office and go to a different provider, but need to know the exchange first.

The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
  Print Thread

Jump to