Technical Discussion
  >> Security Related Issues


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | (show all)   Print Thread
Standard User Fido
(committed) Sun 08-Feb-15 15:31:33
Print Post

I cannot access my own files.


[link to this post]
 
On my main PC I am using windows 8.1: which makes a big deal of being able to distribute your files and information between PCs but I do not like the thought of my files being in a cloud or anywhere that I have not put them and for that reason I do not use the windows based login. - I use the PC based login option and I have removed the cloud files and I disabled all of the file sharing features.

I did not want to be in a home group but the Windows 8.1 system kept setting up a home group for me and my files kept appearing on the home network, (via Network/PC-Name/User/etc), even though I had set the security setting for my files as private after which they disappeared for a while only to reappear there a few weeks later.

Today I got peed off and I overset the file security to deny access to all, (including Administrators, on my own PC), and now I cannot see or access my own files from my own login when I login to my own PC and the desktop icons are all missing.

I can see my files folder from another user account that is set up on the same PC, (When I log into the other user account on the same PC, (which has now been reset to be a Administrator account), I can see my user file but I cannot gain access to my file via this other administrator account.

When I try to carry out a system restore it says that it does not have any restore points.

Is there a way to access my files ?

I do have some of the files backed up onto a USB hard drive but the files on that USB hard disk are six months old and it will take a lot of time and faff to input these old files into the PC and it would probably be better if I reinstalled windows if I ended up down that route as it would be hard to avoid duplication of file names

Kndly advise,
Fido

BT Infinity

Edited by Fido (Sun 08-Feb-15 15:53:47)

Standard User Pipexer
(eat-sleep-adslguide) Sun 08-Feb-15 16:10:47
Print Post

Re: I cannot access my own files.


[re: Fido] [link to this post]
 
Take ownership (ownership tab, advanced button in security tab) of the files with the desired account. Then you can change the permissions back (or hopefully just delete the entry with the "DENY ALL" in)

AAISP Home::1

Edited by Pipexer (Sun 08-Feb-15 17:51:48)

Standard User andygegg
(regular) Sun 08-Feb-15 17:40:28
Print Post

Re: I cannot access my own files.


[re: Fido] [link to this post]
 
Let us know if Pipexer's advice works - the way Win10 works this could become much more of an issue.

And, of course, BACKUP BACKUP BACKUP and then backup again! Think of it like cleaning your teeth!


Register (or login) on our website and you will not see this ad.

Standard User Pipexer
(eat-sleep-adslguide) Sun 08-Feb-15 17:46:19
Print Post

Re: I cannot access my own files.


[re: andygegg] [link to this post]
 
In reply to a post by andygegg:
Let us know if Pipexer's advice works - the way Win10 works this could become much more of an issue.

I am curious, tell me more.. Is this something to do with encryption?

AAISP Home::1
Standard User Fido
(committed) Sun 08-Feb-15 19:18:07
Print Post

Re: I cannot access my own files.


[re: Pipexer] [link to this post]
 
In reply to a post by Pipexer:
Take ownership (ownership tab, advanced button in security tab) of the files with the desired account. Then you can change the permissions back (or hopefully just delete the entry with the "DENY ALL" in)


Prior to my original post I had already to tried take ownership of my own desktop and my own user account files via the other user account, ( which I had reset as another administrator account) but that did not work.

After your replies;

I used the command prompt screen, (via the other user account), to make the hidden Administrator file in windows accessible. (Command prompt Admin to gain access to the windows command processor typing.

C:\Windows\system32> net user administrator /active:yes

to gain access to the hidden Administrator account in windows and at first that seemed to work at first but when I connected the PC to the internet that method failed.

I set up a brand new administrator account and I made sure that the PC had no internet access and I used this NEW administrator account to access my files and I made, (up to date), back up copies.

Next I tried to reset things via the same method that I had used to mess up in the first place. - Right click on the user file - Properties - Security - Permissions and I allowed anything possible permission and restarted in my own user account,

Offline all was well and when I connected the internet all seemed OK.

So I now seem to have regained access to my own files.

Thank you all for your help !

I do have a few security queries regarding this and I will make a separate follow up post to ask about them.

Regards,
fido

BT Infinity
Standard User Fido
(committed) Sun 08-Feb-15 19:58:53
Print Post

Re: I cannot access my own files.


[re: Fido] [link to this post]
 
The reason I lost access to my own files was because I wanted to prevent any network access to my own files and I was somewhat overzealous regarding the security settings.

Using Windows 8.1, what security access permission settings are advised for a user file and how can I stop the windows system from trying to share my files?

In the PC Settings area I have stopped all sharing. - I do not want a Home Group but the system seems to set one up automatically and I have limited the home group that it sets up.

I have tried clicking on my user file in the network area and pressing STOP SHARING but it does not seem to work and if the files are removed the files tend to reappear in the network area some time later.

I have tried to limit access and prevent sharing by editing the file security permission using the - ( Right click on the user file - Properties - Security - Permissions ) - method but it is hard to set the correct access limits and I would welcome advice as to the best settings for this.


Regards,
Fido

BT Infinity
Standard User Pipexer
(eat-sleep-adslguide) Sun 08-Feb-15 20:08:08
Print Post

Re: I cannot access my own files.


[re: Fido] [link to this post]
 
Go into advanced sharing settings.


Homegroup conections, set to ->
"Use user accounts and passwords to connect to other computers". This will turn off the homegroup.

Then, subsequently, turn off network discovery and turn off file and printer sharing.

Nothing should be shared then.

AAISP Home::1
Standard User andygegg
(regular) Mon 09-Feb-15 17:09:19
Print Post

Re: I cannot access my own files.


[re: Pipexer] [link to this post]
 
In reply to a post by Pipexer:
In reply to a post by andygegg:
Let us know if Pipexer's advice works - the way Win10 works this could become much more of an issue.

I am curious, tell me more.. Is this something to do with encryption?


Not encryption - and I might be maligning Win10. Firstly, I've never used Win8 so I don't know how that sets up. When I installed the trial version of Win 10 it wanted to put the usual pseudo folders (Documents, Music, 'Camera Roll' (whatever that is!), etc) into OneDrive. Since then, Win10 has gone back to a distinct OneDrive folder (but the installation will probably try to put Documents, etc into it). Also, the only way to install the trial version of Win10 is with a Microsoft account (which is reasonable) which gets full administrator privileges and other users you set up are non-admin. All these privileges can be changed (with care) but I can see na´ve users installing a very insecure system.
Win10 also sets up with sharing on (username and password required) but this can be switched off easily, much as Pipexer suggests.
Standard User JHo1
(regular) Mon 09-Feb-15 18:12:18
Print Post

Re: I cannot access my own files.


[re: andygegg] [link to this post]
 
"the only way to install the trial version of Win10 is with a Microsoft account ". No, not so. I can't remember exactly how to do it, but it's something like;

choose to set up a new MS account,
at the bottom of the next screen an option to use a local account appears. Select that et voila!

It's fairly similar to 8.1

Watch out if you go into the shop / market / app store / whatever it is called. I have had a warning that my account was "about to be upgraded"!. I thought "oo-err" backed out, checked what it meant and was very glad I didn't proceed.

i think we're all going to get a gun pointed at our heads on this one day but not yet.

John
Standard User Pipexer
(eat-sleep-adslguide) Mon 09-Feb-15 18:41:40
Print Post

Re: I cannot access my own files.


[re: JHo1] [link to this post]
 
Yes this, it does give a way to create a local account but it may not be immediately obvious. This was the same concern with Windows 8.1, people saying it forced people to create local account when it did not at all.

AAISP Home::1
Pages in this thread: 1 | 2 | (show all)   Print Thread

Jump to