Technical Discussion
  >> Technical Issues


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User Gomjaba
(newbie) Mon 23-May-11 13:06:55
Print Post

Cisco 877w dropping connection


[link to this post]
 
I am lurking here for a while now and most of you guys seem to be a helpful bunch so I hope someone here can help me out smile

I am using a Draytek 2920n for a long time now and finally started to use a proper device - or so I hope. Please bear with me because until a few weeks ago I couldn't even spell Cisco smile

First of all, this is on a UK connection (Wholesale connection from Enta) so I hope someone can help me still.

First of all, here the router configuration

http://belcam.net/router-config.txt

the version

http://belcam.net/sh-ver.txt

sh dsl int atm0

http://belcam.net/sh-dsl-int-atm0.txt

sh int dialer0

http://belcam.net/sh-int-dialer0.txt

sh int atm0

http://belcam.net/sh-atm0.txt

I now enabled

debug atm events
debug atm errors

and changed the log size to a MB, but maybe someone has already a clue based on the stuff given smile

Any help is much appreciated. So far I get a lot of hoohaa for me suggesting a lot more expensive piece of kit which turns out to be less stable ..

Oh and I have already enabled interleaving and set the SNR margin to "Super Stable" on the line itself without luck.
Standard User Rockh
(eat-sleep-adslguide) Mon 23-May-11 15:45:42
Print Post

Re: Cisco 877w dropping connection


[re: Gomjaba] [link to this post]
 
Links don't appear to work. Just copy and paste the config bits into the post.

Dave
Standard User Gomjaba
(newbie) Mon 23-May-11 15:49:35
Print Post

Re: Cisco 877w dropping connection


[re: Rockh] [link to this post]
 
In reply to a post by Rockh:
Links don't appear to work. Just copy and paste the config bits into the post.


Ah, restarted Apache due to a config change .. could you try again please ?

Edit: never mind, still a problem, posting configs in a sec

Edited by Gomjaba (Mon 23-May-11 15:54:38)


Register (or login) on our website and you will not see this ad.

Standard User Gomjaba
(newbie) Mon 23-May-11 15:57:29
Print Post

Re: Cisco 877w dropping connection


[re: Gomjaba] [link to this post]
 
Ok, seems like my hoster bombed out the DNS of that domain .. anyway, here the config

!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 4096
enable secret 5 xxx
!
no aaa new-model
clock timezone GMT 0
clock summer-time GMT recurring last Sun Mar 1:00 last Sun Oct 2:00
!
dot11 ssid cheesecake
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7 xxx
!
dot11 ssid chessecake
authentication open
!
no ip source-route
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.13.254
!
ip dhcp pool MikeHome
import all
network 192.168.13.0 255.255.255.0
domain-name titaninternet.co.uk
dns-server xxxx
default-router 192.168.13.254
update arp
!
!
!
multilink bundle-name authenticated
password encryption aes
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-399913742
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-399913742
revocation-check none
rsakeypair TP-self-signed-399913742
!
!
crypto pki certificate chain TP-self-signed-399913742
certificate self-signed 01 nvram:IOS-Self-Sig#5.cer
!
!
!
!
!
bridge irb
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode adsl2+
!
interface ATM0.1 point-to-point
no snmp trap link-status
pvc 0/38
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers tkip
!
ssid cheesecake
!
speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
station-role root
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxx
ppp chap password 7 xxx
ppp pap sent-username xxx password 7 xxx
ppp ipcp dns request
!
interface BVI1
ip address 192.168.13.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.13.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
password 7 xxx
login
no modem enable
line aux 0
password 7 xxx
login
line vty 0 4
password 7 xxx
login
transport input all
!
scheduler max-task-time 5000
ntp server xxx prefer
end


Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(11)XJ3, RELEASE SOFTWARE (fc1)
Synched to technology version 12.4(11)T
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 25-Apr-07 14:27 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YI6, RELEASE SOFTWARE

Router uptime is 2 days, 19 hours, 55 minutes
System returned to ROM by reload at 11:06:12 GMT Fri Mar 1 2002
System image file is "flash:c870-advipservicesk9-mz.124-11.XJ3.bin"
Last reload reason: Reload Command



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 877W-M (MPC8272) processor (revision 0x400) with 236544K/25600K bytes of memory.
Processor board ID FCZ151991FC
MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
4 FastEthernet interfaces
1 ATM interface
1 802.11 Radio
128K bytes of non-volatile configuration memory.
28672K bytes of processor board System flash (Intel Strataflash)

Configuration register is 0x2102


ATM0
Alcatel 20190 chipset information
ATU-R (DS) ATU-C (US)
Modem Status: Showtime (DMTDSL_SHOWTIME)
DSL Mode: ITU G.992.5 (ADSL2+) Annex A
ITU STD NUM: 0x03 0x3
Chip Vendor ID: 'STMI' 'TSTC'
Chip Vendor Specific: 0x0000 0x0510
Chip Vendor Country: 0x0F 0xB5
Modem Vendor ID: 'CSCO' 'TSTC'
Modem Vendor Specific: 0x0000 0x5100
Modem Vendor Country: 0xB5 0xB5
Serial Number Near: FCZ151991FC
Serial Number Far: 00000000000Chip ID: C196P (1) capability-enabled
DFE BOM: DFE3.0 Annex M (3)
Chip ID: C196P (1) capability-enabled
DFE BOM: DFE3.0 Annex M (3)
Capacity Used: 60% 100%
Noise Margin: 14.0 dB 9.0 dB
Output Power: 20.5 dBm 12.5 dBm
Attenuation: 24.0 dB 12.0 dB
Defect Status: None None
Last Fail Code: None
Watchdog Counter: 0xCF
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction: 0x00
Interrupts: 8318 (0 spurious)
PHY Access Err: 0
Activations: 7
LED Status: ON
LED On Time: 100
LED Off Time: 100
Init FW: init_AMR-3.0.014_no_bist.bin
Operation FW: AMR-3.0.014.bin
FW Source: embedded
FW Version: 3.0.14

DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 9728 0 828
Cells: 0 67110 0 15534321
Reed-Solomon EC: 0 11 0 0
CRC Errors: 0 0 0 0
Header Errors: 0 0 0 0
Total BER: 0E-0 0E-0
Leakage Average BER: 0E-0 0E-0
Interleave Delay: 0 25 0 0
ATU-R (DS) ATU-C (US)
Bitswap: enabled enabled
Bitswap success: 0 0
Bitswap failure: 0 0

LOM Monitoring : Disabled


DMT Bits Per Bin
000: 0 0 0 0 0 0 0 7 8 9 A B C B C D
010: D D D D D D D D C C C B B A 9 0
020: 0 4 5 5 5 6 7 6 7 7 7 7 7 7 7 7
030: 7 7 7 7 6 6 5 4 4 4 5 6 7 8 8 9
040: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 A A
050: 9 A 9 9 9 9 2 9 9 A A 9 A A A 9
060: 9 A A 9 9 9 9 9 9 9 9 9 9 9 9 9
070: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
080: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
090: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
0A0: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
0B0: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
0C0: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
0D0: 9 9 9 8 9 9 9 8 8 8 8 8 8 8 8 8
0E0: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8
0F0: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8
100: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8
110: 7 7 7 7 7 2 3 6 7 7 7 7 7 7 7 7
120: 6 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7
130: 7 7 7 7 7 7 7 7 7 7 7 6 7 7 7 7
140: 7 7 7 6 6 6 6 6 5 6 5 4 0 5 5 5
150: 6 6 5 6 5 5 5 5 6 5 5 5 5 5 5 5
160: 4 4 2 0 2 4 5 5 5 5 5 5 5 5 5 5
170: 5 5 4 4 4 4 4 4 4 4 4 4 4 4 4 4
180: 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4
190: 4 4 4 4 4 3 4 3 3 3 3 3 3 3 3 3
1A0: 3 3 3 2 3 2 2 2 2 2 2 2 2 2 2 2
1B0: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2
1C0: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2
1D0: 2 2 2 2 2 2 2 2 2 2 2 2 2 1 0 1
1E0: 2 0 1 1 0 0 0 0 0 0 0 0 0 0 0 0
1F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled


Dialer0 is up, line protocol is up (spoofing)
Hardware is Unknown
Internet address is xx.xx.xxx.xx/32
MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 1 seconds on reset
Interface is bound to Vi1
Last input never, output never, output hang never
Last clearing of "show interface" counters 2d19h
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/16 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 42 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
101934 packets input, 5792823 bytes
93655 packets output, 3944363 bytes
Bound to:
Virtual-Access1 is up, line protocol is up
Hardware is Virtual Access interface
MTU 1500 bytes, BW 828 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Open: IPCP
PPPoE vaccess, cloned from Dialer0
Vaccess status 0x44, loopback not set
Keepalive set (10 sec)
Interface is bound to Di0 (Encapsulation PPP)
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters 02:13:41
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 1 packets/sec
5 minute output rate 1000 bits/sec, 1 packets/sec
7116 packets input, 2774497 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
7214 packets output, 704547 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions


ATM0 is up, line protocol is up
Hardware is MPC ATMSAR (with Alcatel ADSL Module)
MTU 4470 bytes, sub MTU 4470, BW 828 Kbit, DLY 440 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM, loopback not set
Encapsulation(s): AAL5 AAL2, PVC mode
10 maximum active VCs, 1024 VCs per VP, 1 current VCCs
VC Auto Creation Disabled.
VC idle disconnect time: 300 seconds
Last input 02:12:58, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: Per VC Queueing
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
102023 packets input, 9263312 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
93726 packets output, 8497345 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
Standard User DougM
(member) Mon 23-May-11 16:35:20
Print Post

Re: Cisco 877w dropping connection


[re: Gomjaba] [link to this post]
 
I run an 877W on a much longer line (62 dB attenuation), but manage to remain connected reliably.

Main difference I see is the version of IOS and modem firmware. I'm running IOS 12.4(22)T4 and I've overridden the embedded ADSL modem firmware using an external binary at 4.0.18. If you're interested then download from CCO or PM me if you'd like help obtaining them.

Here are the ATM sections of my config, I increased the noise margin to maximum (valid entries are between -3 and 3):

interface ATM0
bandwidth inherit
bandwidth receive inherit
no ip address
ip flow ingress
load-interval 30
no atm ilmi-keepalive
dsl operating-mode adsl2
dsl enable-training-log ondemand
dsl lom 250
dsl noise-margin 3
dsl bitswap both
hold-queue 224 in
end
!
interface ATM0.1 point-to-point
description PVC 0/38
mtu 1500
bandwidth 2500
pvc DATA 0/38
tx-ring-limit 3
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
end


-==-
DougM
Standard User Gomjaba
(newbie) Mon 23-May-11 17:01:23
Print Post

Re: Cisco 877w dropping connection


[re: DougM] [link to this post]
 
Ah cool, didn't know you can set the margin smile

PM incoming smile

In reply to a post by DougM:
I run an 877W on a much longer line (62 dB attenuation), but manage to remain connected reliably.

Main difference I see is the version of IOS and modem firmware. I'm running IOS 12.4(22)T4 and I've overridden the embedded ADSL modem firmware using an external binary at 4.0.18. If you're interested then download from CCO or PM me if you'd like help obtaining them.

Here are the ATM sections of my config, I increased the noise margin to maximum (valid entries are between -3 and 3):

interface ATM0
bandwidth inherit
bandwidth receive inherit
no ip address
ip flow ingress
load-interval 30
no atm ilmi-keepalive
dsl operating-mode adsl2
dsl enable-training-log ondemand
dsl lom 250
dsl noise-margin 3
dsl bitswap both
hold-queue 224 in
end
!
interface ATM0.1 point-to-point
description PVC 0/38
mtu 1500
bandwidth 2500
pvc DATA 0/38
tx-ring-limit 3
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
end
Standard User Gomjaba
(newbie) Thu 26-May-11 14:48:33
Print Post

Re: Cisco 877w dropping connection


[re: Gomjaba] [link to this post]
 
Heh Doug, thanks a lot again .. I have now a fantastic stable connection - although I didn't even have to play with the margain. It must be down to the IOS / Firmware combo ..

I now have a smartnet contract too just in case, but funnily enough the 4.0.018 firmware isn't available to download - I guess it is only available through support .. no need now tongue
Standard User DougM
(member) Thu 26-May-11 15:11:46
Print Post

Re: Cisco 877w dropping connection


[re: Gomjaba] [link to this post]
 
That's great news, glad I could help out.

I'm probably going to sell my Cisco 877W in the next few days, in preparation for migration to FTTC I plan to buy something with an integrated VDSL2 modem.

-==-
DougM
  Print Thread

Jump to