User comments on ISPs
  >> Virgin Media (Cable)


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User chaela
(learned) Thu 22-May-14 04:56:52
Print Post

Not fit for purpose


[link to this post]
 
Last thursday 15th May I was experiancing very slow download speeds, around 0.5Mbps. I checked on the VM status page which said there was maintenance work going which would be finished by 10:30 am. Around lunchtime I was back on the pc and still had the same low speed. I phoned 150, the support guy remotely connected to my pc and informed me that I had file sharing software that was using most of my bandwith. After the conversation was over I set to checking my system and found nothing of the sort so I phoned 150 again, a different cs guy again remotely connected and agreed that there was indeed a problem and arranged for an engineer visit on monday 19th. The engineer arrived, checked something in the street cabinet, fitted a new hub said there was still a problem and it would be fixed within 72 hours. Since then I have been in constant contact with cs and always get the same answer "It will take 24 hours to settle down till you get your speed back"

How the hell can I get through to these erks that there is something seriously wrong with my connection and get them to do something about it.
Standard User Daemon66
(regular) Thu 22-May-14 09:34:55
Print Post

Re: Not fit for purpose


[re: chaela] [link to this post]
 
Virgin have never been known for great customer service but have you tried their own support forums: http://community.virginmedia.com/

The forum support staff are generally pretty good at investigating issues and getting things looked at - well, better than the phone people anyway wink

However, the general approach people take with VirginMedia is that if you have speed problems, run away, run away as fast as your contract allows because it is generally down to over-utilisation in the area and that doesn't get fixed quickly.

Edited by Daemon66 (Thu 22-May-14 09:35:34)

Standard User chaela
(learned) Fri 23-May-14 20:04:46
Print Post

Re: Not fit for purpose


[re: Daemon66] [link to this post]
 
Thanks for response Daemon

I finally got through to a knowledgeable girl at VM cs, she got me to do a tracert and found the problem with one of their servers, which has now been fixed and I'm back on full speed 24/7


Register (or login) on our website and you will not see this ad.

  Print Thread

Jump to