Technical Discussion
  >> Voice over IP (VoIP) Forum


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User picky_user
(regular) Sun 13-Jun-10 17:41:30
Print Post

How to stop being able to hear myself with voip


[link to this post]
 
Hi
When I'm making voip calls with twinkle I can hear myself via the speakers. It's not like an echo you might get in empty room for example. While this is useful if you're trying to check if your mic is working, it's annoying when you're trying to have a conversion. Constantly trying to filter out your own voice.

I'm using twinkle as my client. Is it my client or is it a setting on my ATA/ mic configuration?

Edited by picky_user (Sun 13-Jun-10 17:51:28)

Standard User picky_user
(regular) Mon 14-Jun-10 11:07:14
Print Post

Re: How to stop being able to hear myself with voip


[re: picky_user] [link to this post]
 
I gather this ain't possible then? Alot of ppl have read this post
I 'm using a logitech clearchat comfort usb headset

Edited by picky_user (Mon 14-Jun-10 14:22:20)

Standard User Deadbeat
(knowledge is power) Mon 14-Jun-10 17:03:23
Print Post

Re: How to stop being able to hear myself with voip


[re: picky_user] [link to this post]
 
A headset should automatically disable the speakers. Some "sidetone" in the headset earpice is necessary.


Register (or login) on our website and you will not see this ad.

Standard User drogon
(newbie) Tue 15-Jun-10 10:29:31
Print Post

Re: How to stop being able to hear myself with voip


[re: picky_user] [link to this post]
 
In reply to a post by picky_user:
I gather this ain't possible then? Alot of ppl have read this post
I 'm using a logitech clearchat comfort usb headset


A lot of people have written PhD's on echo cancellation - it's not a trivial subject )-:

However, cancelling echo is very possible - but we've not a lot to go on here. I'm guessing (from your other posts?) You're using twinkle connected to an SPA3000 device and from there calling out over the PSTN - and it's the PSTN calls you get echo on? (Do you get echo on VoIP calls too?)

So what causes echo - almost always it's the far-end, and odd as this may sound, that's by design of the analogue phone system.

In the PSTN world where we pick up an analogue phone, it's digitised at the exchange, sent digitally, then converted back into analogue for the far-end, then, because of the way the analogue circuits work, (we only have 2 wires!) it's sent back to us again, so there is still echo, but it's so fast that we can't hear it. (Typically we can't hear echo if it's under 30ms) We will hear it on long-distance lines (trans atlantic), but that's when the phone companies employ their own echo cancellers.

In a pure digital system we have the equivalent of 4 wires - 2 for send and 2 for receive, so we can completely split speech in both directions and not get echo. (unless the far-end is using a speaker phone!)

When we go from VoIP to analogue, the extra conversion and packetisation times added by our devices on-top of the existing end to end delay is usually long-enough that we start to notice it, so we need to cancel it. Your case takes analogue from your headset, converts it to VoIP in your PC, sends it to the SPA3000 which converts it back to analogue and then it goes over the PSTN. All these conversions add up and can introduce delays that cause echo.

So the place to look is the device you're using to bridge the VoIP and analogue worlds - see what controls it has, what settings, knobs and dials that you can fiddle with. (I'm guessing this is the spa3000 in your case)

In my world where I deploy Asterisk systems connecting to the PSTN, there are a variety of echo cancellers avalable - I've not had much luck with the Linksys, etc. boxes myself, much prefering to use a PCI card in the Asterisk server itself.
Standard User picky_user
(regular) Tue 15-Jun-10 10:44:00
Print Post

Re: How to stop being able to hear myself with voip


[re: drogon] [link to this post]
 
Yes thats right.

I'm using SPA3000 as my ATA so I can make PSTN calls. So what you're saying is it's natural to have echo on a PSTN line but if I was to use voip to voip then I wouldn't get the echo right?

It's only me that has the echo though it seems because everyone I've called can hear me. Nobody has mention there's echo on the line. I wasn't very sure if it's echo because it only happens when I speak into the mic. Otherwise it's perfect.

Edited by picky_user (Tue 15-Jun-10 10:44:45)

Standard User drogon
(newbie) Tue 15-Jun-10 10:54:25
Print Post

Re: How to stop being able to hear myself with voip


[re: picky_user] [link to this post]
 
In reply to a post by picky_user:
Yes thats right.

I'm using SPA3000 as my ATA so I can make PSTN calls. So what you're saying is it's natural to have echo on a PSTN line but if I was to use voip to voip then I wouldn't get the echo right?


You shouldn't get echo on a pure VoIP to VoIP call. Things that will introduce echo are speakerphones which themselves don't have built-in echo cancellation.

In reply to a post by picky_user:
It's only me that has the echo though it seems because everyone I've called can hear me. Nobody has mention there's echo on the line. I wasn't very sure if it's echo because it only happens when I speak into the mic. Otherwise it's perfect.


That's to be expected - people at the far-end on PSTN have the benefit of the echo cancellation provided by their telephone company. You need to "tune" your SPA3000 to do the echo cancelation for you.

Other soft-phones may offer their own echo cancelation though - have you tried X-Lite?
Standard User Deadbeat
(knowledge is power) Tue 15-Jun-10 11:10:08
Print Post

Re: How to stop being able to hear myself with voip


[re: picky_user] [link to this post]
 
Is it the computer speakers or the headset earpieces you can hear. In your OP you seemed to be saying that it was the speakers.

Edited by Deadbeat (Tue 15-Jun-10 11:10:33)

Standard User bluetroll
(fountain of knowledge) Tue 15-Jun-10 14:12:50
Print Post

Re: How to stop being able to hear myself with voip


[re: picky_user] [link to this post]
 
Exactly what you need to do depends on your OS, & possibly soundcard software. What you need to do is make sure the microphone settings are enabled for recording (so the sound goes into the computer) but disabled for playback (so it doesn't come back out of the speakers).

Hope that helps.

"If I have not seen as far as others, it is because giants were standing on my shoulders."
Standard User picky_user
(regular) Tue 15-Jun-10 23:04:52
Print Post

Re: How to stop being able to hear myself with voip


[re: bluetroll] [link to this post]
 
I've already done that. The problem is with this headset, the sidetone isn't individually adjusted. The sidetone is the volume of the mic pick up. Is there anyway I can introduce sidetone using software? It's a logitech clearchat usb headset.

Edited by picky_user (Tue 15-Jun-10 23:07:45)

Standard User valernur
(newbie) Sun 30-Jan-11 20:44:35
Print Post

Re: How to stop being able to hear myself with voip *DELETED*


[re: picky_user] [link to this post]
 
Post deleted by billford
  Print Thread

Jump to