Technical Discussion
  >> Voice over IP (VoIP) Forum


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User mcclaw
(regular) Sat 17-Mar-12 18:56:27
Print Post

CISCO IP 7940


[link to this post]
 
I am trying set up a Cisco 7940 (sip firmware) with AASIP I have entered what I think are the correct setting in the SIP.cnf file but doesn't seem to be registering.

Edited by mcclaw (Sat 17-Mar-12 21:51:05)

ISP Representative viperdude
(isp) Mon 19-Mar-12 13:44:33
Print Post

Re: CISCO IP 7940


[re: mcclaw] [link to this post]
 
Are you behind NAT?

If so you need to set

nat_enable:1

In your SIPDefault.cnf or the individual TFTP file for the phone.
The above post has been made by an ISP REPRESENTATIVE (although not necessarily the ISP being discussed in the post).
Standard User mcclaw
(regular) Mon 19-Mar-12 14:50:50
Print Post

Re: CISCO IP 7940


[re: viperdude] [link to this post]
 
thanks that worked. Not just cant get it to ring when receiving a call and can't hear any sound on speaker or handset once an out going call is connected frown

--- --- ---
Tesco Broadband 23371 kbps / 1023 kbps (don't sign up they are $#!@)
Vivaciti Broadband Unlimited Lite 12286 kbps / 1177 kbps
SDWTRLV exchange with a Draytek 2820Vn
Virgin 100Mb


Register (or login) on our website and you will not see this ad.

ISP Representative viperdude
(isp) Mon 19-Mar-12 15:14:18
Print Post

Re: CISCO IP 7940


[re: mcclaw] [link to this post]
 
OK you may have a number of issues here.

Regarding the phone not ringing on incoming it may be because the phone is set to only re-register every 1 hour and the NAT binding is timing out. Set it to re-register maybe every 5 mins or less and retest.

If you are getting no audio this could be a port blocking or NAT issue. The above suggestion might fix this.

What router are you using and which ISP?
The above post has been made by an ISP REPRESENTATIVE (although not necessarily the ISP being discussed in the post).
Standard User mcclaw
(regular) Mon 19-Mar-12 15:41:46
Print Post

Re: CISCO IP 7940


[re: viperdude] [link to this post]
 
I am using a Draytek 2820 with Virgin Media (cable) and Vivaciti (BE Wholesale)

--- --- ---
Tesco Broadband 23371 kbps / 1023 kbps (don't sign up they are $#!@)
Vivaciti Broadband Unlimited Lite 12286 kbps / 1177 kbps
SDWTRLV exchange with a Draytek 2820Vn
Virgin 100Mb
ISP Representative viperdude
(isp) Mon 19-Mar-12 15:50:59
Print Post

Re: CISCO IP 7940


[re: mcclaw] [link to this post]
 
OK if the Draytek has a SIP ALG then turn it off.

Also check the ISP you are using are not blocking VoIP. Some do restrict it to their own offering from what I have seen.

Edited by viperdude (Mon 19-Mar-12 15:57:28)

The above post has been made by an ISP REPRESENTATIVE (although not necessarily the ISP being discussed in the post).
Standard User mcclaw
(member) Mon 19-Mar-12 16:05:10
Print Post

Re: CISCO IP 7940


[re: viperdude] [link to this post]
 
SIP ALG turned off
dont think ISP is blocking VoIP as I am able use it with a different phone/softphone

--- --- ---
Tesco Broadband 23371 kbps / 1023 kbps
Vivaciti Broadband Unlimited Lite 12286 kbps / 1177 kbps
SDWTRLV exchange with a Draytek 2820Vn
Virgin 100Mb
ISP Representative viperdude
(isp) Mon 19-Mar-12 16:09:32
Print Post

Re: CISCO IP 7940


[re: mcclaw] [link to this post]
 
Can't really help anymore. Probably will need to get your provider to look at the SIP trace to diagnose further.
The above post has been made by an ISP REPRESENTATIVE (although not necessarily the ISP being discussed in the post).
  Print Thread

Jump to