Technical Discussion
  >> Windows Issues


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | (show all)   Print Thread
Standard User mikkoyan
(newbie) Sun 31-Oct-10 22:13:55
Print Post

Speedtest - Strange Java Problem


[link to this post]
 
When trying to run the Thinkbroadband speedtest in IE7 I am told that I need to install Java. It's already installed and up to date. The site invites me to check my Java and says it's up to date.
I've tried upgrading to IE8 and unistalling and reinstalling Java - still the same.
I've had a look through the IE8 tools > internet options but didn't spot anything specific to Java settings.
Any ideas?
Standard User camieabz
(legend) Sun 31-Oct-10 22:15:33
Print Post

Re: Speedtest - Strange Java Problem


[re: mikkoyan] [link to this post]
 
Are you using 64-bit IE?

If so, try the 32-bit (it'll be on there somewhere).

Standard User mikkoyan
(newbie) Sun 31-Oct-10 22:55:30
Print Post

Re: Speedtest - Strange Java Problem


[re: camieabz] [link to this post]
 
I'm using IE8 32 bit (file name IE8-WindowsVista-x86-ENU) with latest Java (file name JavaSetup6u22) and Vista 32 bit OS.
Just been looking for a solution and found this:
http://forums.sun.com/thread.jspa?threadID=5392012
which leads to things that are way over my head so I wonder if there is an easy solution?


Register (or login) on our website and you will not see this ad.

Standard User camieabz
(legend) Sun 31-Oct-10 23:14:57
Print Post

Re: Speedtest - Strange Java Problem


[re: mikkoyan] [link to this post]
 
Perhaps more info:

http://www.windowsbbs.com/internet-explorer/91866-ja...

If you have changed nothing, then you will be running the 32 Bit IE8 and need to install Java 32Bbit


So hopefully, here's the solution:

http://www.java.com/en/download/faq/java_win64bit.xml

(In other words, you'll need the 32-bit plugin for the 32-bit IE, and the 64-bit plugin for the 64-bit IE.)

Standard User petsy
(eat-sleep-adslguide) Sun 31-Oct-10 23:48:49
Print Post

Re: Speedtest - Strange Java Problem


[re: camieabz] [link to this post]
 
In reply to a post by camieabz:
In other words, you'll need the 32-bit plugin for the 32-bit IE, and the 64-bit plugin for the 64-bit IE.)


Hmm, has states he's using 32 bit Vista with the correct version of java
Standard User 12eason
(eat-sleep-adslguide) Sun 31-Oct-10 23:54:27
Print Post

Re: Speedtest - Strange Java Problem


[re: mikkoyan] [link to this post]
 
it says the <applet> tag isn't supported by ie8 as it's depreciated, which is weird i guess. According to that thread it needs site side IE specific <object> tags combined with <embed> for other browsers; http://download.oracle.com/javase/1.5.0/docs/guide/p...

HTML
1
23
45
67
89
1011
12
<object 
  classid="clsid:CAFEEFAC-0015-0000-0000-ABCDEFFEDCBA"  <param name="code" value="Applet1.class">
    <comment>      <embed code="Applet1.class"
        type="application/x-java-applet;jpi-version=1.5.0">        <noembed>
          No Java Support.        </noembed>
      </embed>    </comment>
  </object>

Odd that this hasn't cropped up before though, it's probably not the whole story. Considering tbb is transitional 4.01 and not strict, it should be running in quirks mode. Maybe it isn't doing doctype sniffing properly? Hasn't IE got some weird compatibility mode?

____________________________________________________________________________abusing freechat_______
          Firenet - V21 - Fast4 - f·2·s - eclipseinternet - entanet - aaisp.net

Edited by 12eason (Sun 31-Oct-10 23:55:52)

Standard User mikkoyan
(newbie) Mon 01-Nov-10 00:02:32
Print Post

Re: Speedtest - Strange Java Problem


[re: camieabz] [link to this post]
 
On going to the Java site and verifying my Java version I got the message:

Congratulations!
You have the recommended Java installed (Version 6 Update 22)

So it checked my Java version (32/64) against my OS and said "OK".

Looking at this problem I see a lot of people have been affected with various solutions eg this forum:
http://social.answers.microsoft.com/Forums/en-US/Int...
I tried a few solutions but not yet the complete registry deletions and reinstall of Java.

Still works with Firefox so maybe I stay with FF. Pity IE8 can't get to grips with Java, after all Java applets are still very widely used.
Anonymous
(Unregistered)Mon 01-Nov-10 00:29:32
Print Post

Re: Speedtest - Strange Java Problem


[re: mikkoyan] [link to this post]
 
Had same problem since installing IE8 with Java

Speedtest doesn't work in IE8 but now works fine in in IE9 beta
Standard User camieabz
(legend) Mon 01-Nov-10 01:23:30
Print Post

Re: Speedtest - Strange Java Problem


[re: mikkoyan] [link to this post]
 
Using 6.0.200 here. TBB speedtest works fine.

Edit: IE 8.0.6001

I tried the Speedtest from both IE programs (Program Files for 64-bit amd Program File (x86) for 32-bit). When loading the speedtest for the 64-bit version, I got a Java notification bubble popup on my systray area (bottom right), rather than just a Java icon. Not sure what that means, but can get the speedtest with both IE8 versions.

Edited by camieabz (Mon 01-Nov-10 01:32:37)

Standard User broadband66
(experienced) Mon 01-Nov-10 16:06:48
Print Post

Re: Speedtest - Strange Java Problem


[re: mikkoyan] [link to this post]
 
Have you used Microsoft Update recently?

Was Eclipse Home Option 1 & VM 2Mb
Now O2 standard
Pages in this thread: 1 | 2 | (show all)   Print Thread

Jump to