User comments on ISPs
  >> Zen Internet


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User Pipexer
(eat-sleep-adslguide) Sun 17-Feb-13 14:55:04
Print Post

Good service


[link to this post]
 
The IP profile on my line had stuck once again (5th time now in 4 years...) - noticed slowdown on Friday, didn't think anything of it, but when I ran a speedtest on Saturday morning, I noticed it was uncannily pegged at 2Mbps.

Phoned support - call picked up immediately, spoke to someone called Chris, really helpful, said he would run tests and call back in 5 minutes, which he did, and then logged the first phase fault with BT, he said it might not work but give it 24 hours and then call back.

This didn't work, so called today, spoke to another chap (can't remember his name), right to the point and he raised it as a stuck BRAS.

Speed has returned now.

Really impressed - both people who I spoke to were right to the point, no messing about at all.

Zen 8000 Pro
Standard User lodge
(committed) Wed 20-Feb-13 14:29:05
Print Post

Re: Good service


[re: Pipexer] [link to this post]
 
I can echo the good service comments.

I lost broadband connectivity at 17:40 last night and reported the fault to Zen. After the usual diagnostics and waiting to hear from BT, they telephoned me back at 19:40 and fixed an appointment for BT to come out this morning.

The engineer arrived at 09:00 and replaced what turned out to be a faulty card in the exchange.
He couldn't believe that I only raised the fault last night, since he said that for example, the lead time for a new line is 5 weeks in this area at the moment.

Well done Zen.
  Print Thread

Jump to