User comments on ISPs
  >> Zen Internet


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User MrDoom
(committed) Thu 30-Oct-14 23:14:07
Print Post

PPP connection dropping under load


[link to this post]
 
Hey,

I've been having an issue recently where my PPP connection will drop when my internet is placed under heavy load. The PPP connection claims to come back up again afterwards, however the connection is bogus and I can't access the internet again until I power-cycle my router (TP-LINK TD-W8980 - according to its diagnostic tests, it fails to ping the DNS servers, but I can't connect to anything via a direct IP address either). At no point does my DSL sync drop.

Usually my internet connection is stable, but there's a certain application that I can use to reproduce this problem with 100% reproducibility. Said application is trying to download 3GB using 8 simultaneous connections, and will get somewhere between 300 - 700MB through the download before my PPP connection drops.

Looking at my router logs, it seems the PPP drop is in response to an LCP TermReq message:

2014-10-18 13:05:38 [6] PPP: ppp0 rcvd [LCP TermReq id=0xcb]
2014-10-18 13:05:38 [3] PPP: ppp0 LCP down
2014-10-18 13:05:38 [4] PPP: ppp0 LCP down
2014-10-18 13:05:38 [6] PPP: ppp0 sent [LCP TermAck id=0xcb]

I'm connected to the Leamington Spa exchange, which is apparently LLU enabled.

Any thoughts?

Thanks.

ZeN Pro
Standard User MrDoom
(committed) Fri 31-Oct-14 00:56:54
Print Post

Re: PPP connection dropping under load


[re: MrDoom] [link to this post]
 
Wow, the PPP connection just dropped while streaming from Spotify, and this time didn't even pretend to reconnect... that's not even close to heavy usage.

I've swapped out my TP-LINK TD-W8980 for a Billion BiPAC 8800NL - let's see if that performs any better.

EDIT: Nope, just dropped again while talking to someone on IM, and refused to reconnect without a power cycle frown

ZeN Pro

Edited by MrDoom (Fri 31-Oct-14 01:57:20)

ISP Representative Azzaka
(isp) Fri 31-Oct-14 07:10:09
Print Post

Re: PPP connection dropping under load


[re: MrDoom] [link to this post]
 
Lo Bud,

Have you manually set your DNS servers on the LAN connected device? or are you getting it from DHCP?

Also when it drops/stops, have you tested any other devices? I'm trying to isolate the issue.

Leo Goile
---
ZeN Internet
Service Assurance Engineer
ZeN are recruiting! Click here to view the opportunities available.

I Sync', I Auth', therefore I am.
Online
The above post has been made by an ISP REPRESENTATIVE (although not necessarily the ISP being discussed in the post).


Register (or login) on our website and you will not see this ad.

Standard User MrDoom
(committed) Fri 31-Oct-14 09:10:18
Print Post

Re: PPP connection dropping under load


[re: Azzaka] [link to this post]
 
Hey,

All of my devices automatically pick their DNS servers, although I did try manually setting them on my PC the first time I had this issue, however that didn't help. When it does die, no devices connected to my LAN can access the internet.

My connection has been stable again now for 7 hours, so I'm wondering if the two unusual drops (the ones that happened when not under load, and didn't come back up) were a result of this:
http://status.zensupport.co.uk/active/5/3923

I'll try it again under load later, I've got to go to work now.

Thanks.

ZeN Pro
Standard User MrDoom
(committed) Fri 31-Oct-14 23:23:36
Print Post

Re: PPP connection dropping under load


[re: MrDoom] [link to this post]
 
21.5 hours without a drop, and I've managed to download the thing that was previously causing me a 100% drop!

Fingers crossed that the BiPAC had improved the situation.

ZeN Pro
ISP Representative Azzaka
(isp) Tue 04-Nov-14 17:01:27
Print Post

Re: PPP connection dropping under load


[re: MrDoom] [link to this post]
 
Ahh it could have been.

How is it looking now?

Leo Goile
---
ZeN Internet
Service Assurance Engineer
ZeN are recruiting! Click here to view the opportunities available.

I Sync', I Auth', therefore I am.
Online
The above post has been made by an ISP REPRESENTATIVE (although not necessarily the ISP being discussed in the post).
Standard User MrDoom
(committed) Tue 04-Nov-14 21:13:11
Print Post

Re: PPP connection dropping under load


[re: Azzaka] [link to this post]
 
It's been fine since then, the connection has been up constantly for almost 5 days, and the router log shows no drops.

Hopefully the BiPAC has fixed whatever was causing the drop under load, and the weirdness I saw at the weekend was just caused by maintenance.

I'll post here again if I run into any more PPP drop issues.

Thanks.

ZeN Pro
ISP Representative Azzaka
(isp) Fri 07-Nov-14 00:00:06
Print Post

Re: PPP connection dropping under load


[re: MrDoom] [link to this post]
 
Great.

I'll keep an eye on the thread just in case.

Leo Goile
---
ZeN Internet
Service Assurance Engineer
ZeN are recruiting! Click here to view the opportunities available.

I Sync', I Auth', therefore I am.
Online
The above post has been made by an ISP REPRESENTATIVE (although not necessarily the ISP being discussed in the post).
  Print Thread

Jump to