User comments on ISPs
  >> Zen Internet


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | 3 | (show all)   Print Thread
Standard User sawyert
(newbie) Tue 04-Aug-15 22:33:56
Print Post

Router Problem


[link to this post]
 
My cabinet has finally been upgraded for Fibre, and it's being activated this Friday. Zen have provided me with a free router (a TG589N) and I'm having an odd problem with it on my existing ADSL line.

If I ssh into my server (from an Ubuntu box via Konsole), and then do an ls, the output stops halfway through. If I push enter, then I get the rest. So here:

postgres@bbr:/tmp$ ls
events.csv fail2banclient.out gunicorn_bbn.pid gunicorn_bbr.pid gunicorn_CradleForNature.pid gunicorn_rtb.pid library.csv
events.tsv gunicorn_baydon.pid gunicorn_bb.pid gunicorn_bnb.pid gunicorn_drumcoder.pid gunicorn_wow.pid news.csv
postgres@bbr:/tmp$
postgres@bbr:/tmp$

The output stopped after gunicorn_bbr.pid the first time I tried this, and after fail2banclient.out the second time. Pressing enter always gives me the rest of the (presumably buffered) output. The same is happening with any shell output. sftp doesn't work at all - the connection is stalling and I have no way of kicking it into life with the enter key.

I've just swapped back to my old ADSL router, and everything is fine, so it's definitely something to do with the new router.

Has anyone got any suggestions as to what to tweak? Is the problem likely to go away when I get FTTC? Is the router faulty?

Many thanks,

Tim.
Standard User ZenInternetPR
(newbie) Wed 05-Aug-15 10:31:15
Print Post

Re: Router Problem


[re: sawyert] [link to this post]
 
Hi,

The free router we support at Zen is suitable for a standard set up but not for use as you describe due to a known bug in the firmware. As this legacy firmware is not in any further development there is no fix scheduled for it to be used in this way.

If you have any concerns about other aspects of the functionality of this router, or would like to talk through in more detail, please call us on 01706 902000.

Thanks,

The Zen Team.
Standard User sawyert
(newbie) Wed 05-Aug-15 12:14:55
Print Post

Re: Router Problem


[re: ZenInternetPR] [link to this post]
 
Thanks.

Can you define "standard set up" please? What do you perceive as non-standard, linux? ssh?

Do you have a link I can access with more details about the firmware bug?

Cheers,

Tim.

Edited by sawyert (Wed 05-Aug-15 14:20:57)


Register (or login) on our website and you will not see this ad.

Standard User Cammy
(regular) Wed 05-Aug-15 14:02:58
Print Post

Re: Router Problem


[re: sawyert] [link to this post]
 
I'm getting Zen fibre next week so this has caught my attention.

Where is your server located - ie is the server local and the router is just acting as a switch - or is it remote and the router is somehow buffering traffic to the Internet?
Standard User sawyert
(newbie) Wed 05-Aug-15 14:19:06
Print Post

Re: Router Problem


[re: Cammy] [link to this post]
 
Internal servers in my local network (behind the router) are fine.

The ssh problem occurs with remote servers out in the wild west of the internet. The router is affecting traffic somehow. I also suspect it has broken my access to my work VPN, though I haven't confirmed the router as cause yet.
Standard User Cammy
(regular) Wed 05-Aug-15 14:31:00
Print Post

Re: Router Problem


[re: sawyert] [link to this post]
 
OK, now I'm worried. I SSH out all the time and I would not describe what I do as non "standard". In any case, it's all encapsulated inside SSL so how on earth can the router differentiate SSH from HTTPS (apart from the port).

So Zen, please elaborate on the bug so I know whether I need to buy a different router.
Standard User Pontefract
(committed) Wed 05-Aug-15 14:49:55
Print Post

Re: Router Problem


[re: sawyert] [link to this post]
 
Might be some useful info here:

http://mybroadband.co.za/vb/showthread.php/596671-FO...

--
Paul Simpson

The opinions expressed in posts on this forum are entirely my own. They should not be seen as reflecting the views of my employer or as having been authorized or approved by anyone other than me.

PLEASE NOTE; I will not respond to unsolicited private messages.
Standard User IamQ
(experienced) Wed 05-Aug-15 16:52:54
Print Post

Re: Router Problem


[re: ZenInternetPR] [link to this post]
 
In reply to a post by ZenInternetPR:
Hi,

The free router we support at Zen is suitable for a standard set up but not for use as you describe due to a known bug in the firmware. As this legacy firmware is not in any further development there is no fix scheduled for it to be used in this way.


Hang on... Is Zen telling us they are supplying hardware that is not fit for use in any environment where SSH or VPN connectivity is required?!?!?!

Can we have some clarification from Zen please as to what you term 'standard' setup and use ASAP.

Raises the question why are you providing shonky hardware with known bugs, and why this is not made obvious to new users?

The OP may have redress if the hardware provided is not fit for purpose - certainly you can return it at Zen's expense if nothing else!

Edited by IamQ (Wed 05-Aug-15 16:53:45)

Standard User sawyert
(newbie) Wed 05-Aug-15 21:56:11
Print Post

Re: Router Problem


[re: sawyert] [link to this post]
 
To confirm - my work VPN does not work with the provided TG389N V3 router. It does work with my old Zyxel.

It manifests in a wierd way - I can connect to the VPN fine, but I appear to have no DNS once I'm connected. All this is on Windows 7, no Linux involved.
Standard User mixt
(fountain of knowledge) Thu 06-Aug-15 12:22:54
Print Post

Re: Router Problem


[re: ZenInternetPR] [link to this post]
 
I'm baffled why you would continue to promote and sell a router with such a blatant flaw in its firmware. Not fit for purpose, in my opinion.

Zen Unlimited Fibre | IPv6 via HE | » Automated Hourly HTTPx5 TBB Speed Tests «
Previous ISPs » aaisp.net (40/10Mb FTTC) | Virgin Media (50Mb/Cable) | Be* Un Limited (ADSL2+) | Zen (ADSL)
Download Maximiser | BIND GeoDNS | Are you being blÝcked?
Pages in this thread: 1 | 2 | 3 | (show all)   Print Thread

Jump to