User comments on ISPs
  >> Zen Internet


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User melevittfl
(newbie) Mon 25-Jun-18 09:23:43
Print Post

Strange connection/timeout issues


[link to this post]
 
Hi,

Ever since this planned outage on the 2nd of May (https://servicealerts.zen.co.uk/archive/5/5126), I've noticed that often times loading pages in a browser or content within an app will timeout or just never load.

It's almost like heavy congestion, but this happens regardless of the time of day. Now, the odd thing is that, when I first joined Zen, I was getting very low single-thread speeds, but that's been fixed and now the TBB speedtest regularly shows a single-thread speed fairly close to the multi-thread test speed.

Not exactly sure how to proceed with this as I can't pinpoint any particular problem so I haven't tried Zen support, mostly because I don't know what to point to as the problem.

Anyone else see similar issues and have any idea what the problem might be?

Thanks,
Mark
Standard User melevittfl
(newbie) Tue 26-Jun-18 08:01:03
Print Post

Re: Strange connection/timeout issues


[re: melevittfl] [link to this post]
 
Hi,

I've noticed the graph from my BQM shows a couple of points where the connection was dropping packets. I'm wondering if this is indicative of what I've been experiencing. That is, randomly the connection is dropping packets and then recovers:
My Broadband Ping

Anyone have any insight or possible next steps to troubleshoot?
Administrator MrSaffron
(staff) Tue 26-Jun-18 16:34:58
Print Post

Re: Strange connection/timeout issues


[re: melevittfl] [link to this post]
 
The red spikes at 3am and 7.45am may have been noticeable, but otherwise nothing to indicate a specific problem that is enough to affect throughput generally

The yellow between 6pm and 8pm has all the hallmarks of you using the connection

The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.


Register (or login) on our website and you will not see this ad.

Standard User melevittfl
(newbie) Wed 04-Jul-18 04:41:34
Print Post

Re: Strange connection/timeout issues


[re: MrSaffron] [link to this post]
 
Line syncs at around 72 down, 19 up.

Managed to run a speedtest when the problem seems to be happening and it's pretty bad:

My Broadband Speed Test

A few seconds later, I ran it again and it was back to normal.

(This is on a wired connection, not wifi)
Administrator MrSaffron
(staff) Thu 05-Jul-18 10:12:52
Print Post

Re: Strange connection/timeout issues


[re: melevittfl] [link to this post]
 
Is it always behaving that oddly on the main HTTPx6 test? I'd recommend testing on a second device to rule out AV/PC issues

The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
Standard User melevittfl
(newbie) Sat 07-Jul-18 10:24:13
Print Post

Re: Strange connection/timeout issues


[re: MrSaffron] [link to this post]
 
Hi,

It's a Mac so I doubt it's a virus.

Just tested on a different machine and seeing slow single thread throughput now. I had this problem when first connected to Zen and they did something to fix it, but now it seems to be an issue again.

The modem is still syncing at about 78,000 down and 21,000 up

This seems to have started yesterday afternoon after the PPPoE connection dropped briefly.

My Broadband Speed Test

and BQM graph here:
My Broadband Ping


Modem stats here:
Modem Stats

# xdslcmd info --stats
xdslcmd: ADSL driver and PHY status
Status: Showtime
Retrain Reason: 1
Last initialization procedure status: 0
Max: Upstream rate = 21282 Kbps, Downstream rate = 78048 Kbps
Bearer: 0, Upstream rate = 19999 Kbps, Downstream rate = 78304 Kbps
Bearer: 1, Upstream rate = 0 Kbps, Downstream rate = 0 Kbps
Link Power State: L0
Mode: VDSL2 Annex B
VDSL2 Profile: Profile 17a
TPS-TC: PTM Mode(0x0)
Trellis: U:ON /D:ON
Line Status: No Defect
Training Status: Showtime
Down Up
SNR (dB): 3.3 6.8
Attn(dB): 15.3 0.0
Pwr(dBm): 13.2 6.7
VDSL2 framing
Bearer 0
MSGc: -6 26
B: 243 237
M: 1 1
T: 0 42
R: 10 16
S: 0.0992 0.3781
L: 20479 5374
D: 8 1
I: 254 127
N: 254 254
Q: 8 0
V: 0 0
RxQueue: 63 0
TxQueue: 21 0
G.INP Framing: 18 0
G.INP lookback: 21 0
RRC bits: 0 24
Bearer 1
MSGc: 186 -6
B: 0 0
M: 2 0
T: 2 0
R: 16 0
S: 5.3333 0.0000
L: 48 0
D: 3 0
I: 32 0
N: 32 0
Q: 0 0
V: 0 0
RxQueue: 0 0
TxQueue: 0 0
G.INP Framing: 0 0
G.INP lookback: 0 0
RRC bits: 0 0
Counters
Bearer 0
OHF: 0 4069867
OHFErr: 1 523
RS: 3343319264 268149
RSCorr: 69833 3691
RSUnCorr: 0 0
Bearer 1
OHF: 5183439 0
OHFErr: 0 0
RS: 62200529 0
RSCorr: 0 0
RSUnCorr: 0 0

Retransmit Counters
rtx_tx: 4885294 11779
rtx_c: 3672 13622
rtx_uc: 96483 0

G.INP Counters
LEFTRS: 56 56
minEFTR: 78321 19997
errFreeBits: 2515071741 320106979

Bearer 0
HEC: 0 0
OCD: 0 0
LCD: 0 0
Total Cells: 3947612815 0
Data Cells: 427223712 0
Drop Cells: 0
Bit Errors: 0 0

Bearer 1
HEC: 0 0
OCD: 0 0
LCD: 0 0
Total Cells: 0 0
Data Cells: 0 0
Drop Cells: 0
Bit Errors: 0 0

ES: 22 3944
SES: 21 0
UAS: 93 72
AS: 83262

Bearer 0
INP: 49.00 0.00
INPRein: 0.00 0.00
delay: 0 0
PER: 0.00 3.98
OR: 0.01 64.22
AgR: 78384.77 20063.54

Bearer 1
INP: 4.00 0.00
INPRein: 4.00 0.00
delay: 3 0
PER: 16.06 0.01
OR: 95.62 0.01
AgR: 95.62 0.01

Bitswap: 23162/23162 3639/3643

Total time = 1 days 3 hours 19 min 47 sec
FEC: 1093392 153501
CRC: 1126 4215
ES: 22 3944
SES: 21 0
UAS: 93 72
LOS: 2 0
LOF: 19 0
LOM: 0 0
Latest 15 minutes time = 4 min 47 sec
FEC: 84 3
CRC: 0 4
ES: 0 3
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0
Previous 15 minutes time = 15 min 0 sec
FEC: 406 3
CRC: 0 4
ES: 0 4
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0
Latest 1 day time = 3 hours 19 min 47 sec
FEC: 13873 129
CRC: 0 145
ES: 0 133
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0
Previous 1 day time = 24 hours 0 sec
FEC: 69452 3782
CRC: 551 378
ES: 11 338
SES: 10 0
UAS: 34 24
LOS: 1 0
LOF: 9 0
LOM: 0 0
Since Link time = 23 hours 7 min 41 sec
FEC: 69833 3691
CRC: 1 523
ES: 1 471
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0
#



# xdslcmd info --pbParams
xdslcmd: ADSL driver and PHY status
Status: Showtime
Retrain Reason: 1
Last initialization procedure status: 0
Max: Upstream rate = 21282 Kbps, Downstream rate = 78048 Kbps
Bearer: 0, Upstream rate = 19999 Kbps, Downstream rate = 78304 Kbps
Bearer: 1, Upstream rate = 0 Kbps, Downstream rate = 0 Kbps
Discovery Phase (Initial) Band Plan
US: (7,32) (871,1205) (1972,2782)
DS: (33,859) (1216,1961) (2793,3970)
Medley Phase (Final) Band Plan
US: (7,32) (871,1205) (1972,2782)
DS: (33,859) (1216,1961) (2793,3970)
VDSL Port Details Upstream Downstream
Attainable Net Data Rate: 21282 kbps 78048 kbps
Actual Aggregate Tx Power: 6.7 dBm 13.2 dBm
====================================================================================
VDSL Band Status U0 U1 U2 U3 U4 D1D2 D3
Line Attenuation(dB): 3.8 20.0 30.8 N/A N/A 10.2 24.5 38.4
Signal Attenuation(dB): 3.8 19.1 29.9 N/A N/A 11.4 24.3 38.4
SNR Margin(dB): 6.9 6.8 6.9 N/A N/A 3.3 3.3 3.3
TX Power(dBm): -5.6 -23.9 6.4 N/A N/A 9.9 7.9 7.0
Administrator MrSaffron
(staff) Sun 08-Jul-18 16:38:12
Print Post

Re: Strange connection/timeout issues


[re: melevittfl] [link to this post]
 
NOTE Never said it was virus, I said anti-virus since the inspect some packages do can affect the shape of testing profiles.

Your latest test result in the post is IPv6 versus IPv4 of the other

Edited by MrSaffron (Sun 08-Jul-18 16:39:17)

The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
Standard User melevittfl
(newbie) Mon 09-Jul-18 16:05:26
Print Post

Re: Strange connection/timeout issues


[re: MrSaffron] [link to this post]
 
Ah, I see. No, nothing doing packet inspection.
Standard User melevittfl
(newbie) Thu 12-Jul-18 09:10:57
Print Post

Re: Strange connection/timeout issues


[re: melevittfl] [link to this post]
 
Maybe this is symptomatic of the same single-threaded speed issue Zen seem to suffer from.

I had this problem when I first joined, and it seems to have returned:

My Broadband Speed Test

(This is IPv4)

The BQM graphs for my connection are also showing brief periods with high latency.

My Broadband Ping
  Print Thread

Jump to