Technical Discussion
  >> DSL Hardware Discussion


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | 3 | [4] | 5 | (show all)   Print Thread
Anonymous
(Unregistered)Fri 01-Oct-10 18:51:12
Print Post

Re: DG834N Wlan Uptime Puzzle


[re: has] [link to this post]
 
I also have the DG834N and it also disconnects me at midnight. But this only happens on my PS3. Dont know what it is either!
Anonymous
(Unregistered)Sun 06-Feb-11 13:31:55
Print Post

Re: DG834N Wlan Uptime Puzzle


[re: Anonymous] [link to this post]
 
I have the same router and mine also disconnects & reconnects at midnight! It must be related to this model
Standard User AbandonShip
(fountain of knowledge) Tue 08-Feb-11 00:46:30
Print Post

Re: DG834N Wlan Uptime Puzzle


[re: Anonymous] [link to this post]
 
As I recall, the schedule feature uses crontab to restart the firewall at midnight, it is probably to do with that.


Register (or login) on our website and you will not see this ad.

Standard User koolkp3
(member) Mon 14-Feb-11 02:03:00
Print Post

Re: DG834N Wlan Uptime Puzzle


[re: AbandonShip] [link to this post]
 
I wonder if we will ever see a firmware fix for this as previous firmwares did not have this issue at all. Apart from the Wifi glitch, this router is rock solid.

24Mb
Be There
Standard User AbandonShip
(fountain of knowledge) Sat 26-Feb-11 21:28:49
Print Post

Re: DG834N Wlan Uptime Puzzle


[re: koolkp3] [link to this post]
 
Sadly mine's not so rock solid, it started developing the red light of death syndrome (where it won't restart after a power outage until it has completely cooled off) after just three months.
Currently I've got it in pieces as I was trying to fit heatsinks to it. One on the BCM6358 helped a little, but the main culprit is the wifi, which is under 3 layers of steel shielding which I will probably have to desolder.

The firewall restarting issue which causes the connection to freeze at midnight occurred on mine on one of the previous firmwares, so it might not be the same thing, although as I recall, I did manage to find a fix, I think fiddling around with the schedule settings, but I don't remember exactly what I did.

Ah! I just found a post about it: I discovered that messing around with the schedule settings in a particular way corrupted the crontab entry used to restart the firewall so that it is skipped, curing the issue I had - I don't know if it works in the current firmware, but I posted about it in this thread :- http://forums.thinkbroadband.com/zen/f/3184832-load-...

Thinking about it, as I recall, the current firmware allows you to use the schedule feature to drop the wifi connection, as well as schedule firewall rules, so it probably is related, although there may be a separate crontab entry for dropping wifi, or they may be combined.

Edited by AbandonShip (Sat 26-Feb-11 21:30:14)

Standard User koolkp3
(member) Tue 01-Mar-11 02:40:59
Print Post

Re: DG834N Wlan Uptime Puzzle


[re: AbandonShip] [link to this post]
 
I didn't think of trying that. I will experiment and see how it goes over the next 24 hours wink

24Mb
Be There
Standard User AbandonShip
(fountain of knowledge) Tue 01-Mar-11 13:31:17
Print Post

Re: DG834N Wlan Uptime Puzzle


[re: koolkp3] [link to this post]
 
I'd suggest enabling telnet:- http://192.168.0.1/?todo=debug
and doing a "cat /etc/crontab" before, then after unticking everyday and all the day of the weeks in the schedule entries, to see if it still has the desired effect in the current firmware.


If it works, you should see something similar to below, although here I'm using a different Netgear model, which actually calls the service it restarts "schedule" rather than "firewall"
Password:


BusyBox v1.00 (2008.02.23-08:21+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

#
# cat /etc/crontab
SHELL=/bin/sh
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin
MAILTO=root
HOME=/
DAYLIGHT=1
TZ=GMT+0

0 12 * * * root /usr/sbin/rc ddns start
0 0 * * 0,1,2,3,4,5,6 root /usr/sbin/rc schedule restart <--Restarts "schedule" at midnight on each day of the week
0 * * * * root killall -1 syslogd
#




# cat /etc/crontab
SHELL=/bin/sh
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin
MAILTO=root
HOME=/
DAYLIGHT=1
TZ=GMT+0

0 12 * * * root /usr/sbin/rc ddns start
0 0 * * root /usr/sbin/rc schedule restart <--- Fifth parameter is missing so this line will be ignored
0 * * * * root killall -1 syslogd
#
#



Oh, one other thing, I think you may find that if you make a backup the router settings while the schedule feature is disabled in this way (ie broken), the router might reject the settings file if you try to restore it.

Edited by AbandonShip (Tue 01-Mar-11 13:46:34)

Standard User koolkp3
(member) Wed 02-Mar-11 19:23:37
Print Post

Re: DG834N Wlan Uptime Puzzle


[re: AbandonShip] [link to this post]
 
Well after following your steps I found some interesting stuff there, some extra lines as follows:
BusyBox v1.00 (2008.12.10-11:52+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

# cat /etc/crontab
SHELL=/bin/sh
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin
MAILTO=root
HOME=/
DAYLIGHT=1
TZ=GMT+0

0 12 * * * root /usr/sbin/rc ddns start
0-59 * * * * root /usr/sbin/rc check_conn start
0 0 * * root /usr/sbin/rc schedule restart
0 * * * * root killall -1 syslogd
0 0 * * * root /usr/sbin/rc sch_wlan restart
#
#

Now i just need to find a way to remove that line from the crontab jobs list....

I'm not sure, but I believe that:

crontab -r 0 0 * * * root /usr/sbin/rc sch_wlan restart

should do the trick. I'll be the guinea pig for this and see if it works tonight.

24Mb
Be There

Edited by koolkp3 (Wed 02-Mar-11 19:33:00)

Standard User AbandonShip
(fountain of knowledge) Wed 02-Mar-11 20:34:36
Print Post

Re: DG834N Wlan Uptime Puzzle


[re: koolkp3] [link to this post]
 
Yes, that line does look to be the cause of your problem, pity it has not been broken along with the schedule restart one.

You could probably use grep to re-create crontab without the sch_wlan restart entry, but unfortunately, the changes will be lost next time you lose and re-establish a PPP connection.


If I've got it right, the following should do so, omitting lines containing "restart"

grep -v "restart" /etc/crontab>/etc/t;cp /etc/t /etc/crontab


One thing that might do as a workaround, is to set the start and end time in the schedule to a time when you are unlikely to be using the wireless.

If there's a separate schedule entry for wireless in the router's nvram, modifying it (eg to match the broken "fw_schedule" entry) might also work. Do be careful if altering nvram settings though, I recently bricked a non-netgear router by modifying its settings file (I can still flash firmware onto it, but it hangs before it checks for the reset button to clear its nvram).

Edited by AbandonShip (Wed 02-Mar-11 21:03:51)

Standard User koolkp3
(member) Thu 03-Mar-11 19:09:50
Print Post

Re: DG834N Wlan Uptime Puzzle


[re: AbandonShip] [link to this post]
 
Yeah that was my concern, affecting the router permanently. I will have to find time to do some solid research into the matter wink

24Mb
Be There
Pages in this thread: 1 | 2 | 3 | [4] | 5 | (show all)   Print Thread

Jump to