Technical Discussion
  >> DSL Hardware Discussion


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | [2] | (show all)   Print Thread
Standard User AgedDex
(newbie) Mon 02-Nov-15 07:34:33
Print Post

Re: Trouble with NETGEAR Router DGN2200 Port Forwarding FAIL


[re: BLaZiNgSPEED] [link to this post]
 
Does the DGN2200 have the option to create custom services to add to the firewall rules?

Have you port forwarded on this router before with no problems?

Can you provide an example of the firewall rule you are trying to create.
Standard User BLaZiNgSPEED
(learned) Mon 02-Nov-15 12:53:51
Print Post

Re: Trouble with NETGEAR Router DGN2200 Port Forwarding FAIL


[re: AgedDex] [link to this post]
 
Yes, it does. But even if I attempt to open the ports that way the same error occurs.
Printscreen of my Port Forwarding Attempt
Printscreen Failure The specified port(s) are being used by other configurations
Almost none of the ports can be opened because of this error message. There is something corrupted that doesn't fix itself even with a factory reset.

Even if I install latest firmware and factory reset or do so with the older firmware the same thing happens.

I didn't have this issue 2 years ago when I did port forward on the exact same router with the same Sky ISP Provider.

I can even confirm that it is not a setting issue with any of the computers. As plugging the old Sagem [email protected] that Sky provided has no issues with port forwarding, nor does the Netgear DGN2000 have that issue. But the problem is that the Sagem [email protected] has developed another technical issue where you have to wait 45 minutes or the light on the router will remain orange. While the DGN2000 is incompatible with Sky as the speed becomes less than 1 Mbps.

Otherwise I wouldn't have bothered trying to fix this issue on the DGN2200 if I didn't have the other problems with the other 2 routers.
Standard User Michael_Chare
(experienced) Mon 02-Nov-15 13:43:11
Print Post

Re: Trouble with NETGEAR Router DGN2200 Port Forwarding FAIL


[re: BLaZiNgSPEED] [link to this post]
 
Have you tried creating a new service for the port range that you want to forward?

Michael Chare


Register (or login) on our website and you will not see this ad.

Standard User RobertoS
(elder) Mon 02-Nov-15 14:28:51
Print Post

Re: Trouble with NETGEAR Router DGN2200 Port Forwarding FAIL


[re: BLaZiNgSPEED] [link to this post]
 
I just googled "port forwarding netgear dgn2200" and it came up with loads of results that didn't suggest it is a problem.

The first one, but loads more including screenshots.
...
How about smilo's post on this page?

The indispensable man or woman passes from the scene, and what happens next is more or less the same thing as was happening before.
My broadband basic info/help site - www.robertos.me.uk. Domains, site and mail hosting - Tsohost.
Connection - AAISP Home::1 80/20. Sync 59997/15142kbps @ 600m. - BQM
Standard User BLaZiNgSPEED
(learned) Mon 02-Nov-15 15:55:24
Print Post

Re: Trouble with NETGEAR Router DGN2200 Port Forwarding FAIL


[re: RobertoS] [link to this post]
 
Well it seems like I just found the solution to the problem!

Basically I had to go to Diagnostics--->Reboot the Router. Clicking on Reboot button and then immediately going to the Firewall Rules and quickly setting Any(All) works. Now all ports are open!

However, if I delay for more than say 30 seconds after the reboot and attempt to port forward. It will fail again. This procedure has to be done almost immediately after Rebooting the router!

Also making any other additional changes in the Router settings will break the system again and the ports will be closed. And you have to Reboot the router from the Diagnostics setting again and only then will it allow me to port forward without the Failure message to appear...

But I still consider it a defect in the system/software configuration of this particular router. I have tried doing the same thing in the other routers and this does not happen.

Also this doesn't help me open the ports in my other 2 computers. If I try to set Any(ALL) for the other 2 static ip addresses the Failure message will appear again. And then it will break the port forwarding in my first configured PC. And then I have to redo the procedure again from scratch to Reboot Router and then Add Any(ALL) in order to reopen the ports to my PC again.

This is definitely a bug. As others have complained in that thread where smilo posted. They say that V1.0.0.36_7.0.20 firmware fixes it. However, I cannot find this firmware update in the official Netgear Support or anywhere on the internet in order to experiment to see if it will fix it.
Standard User AgedDex
(newbie) Mon 02-Nov-15 16:09:16
Print Post

Re: Trouble with NETGEAR Router DGN2200 Port Forwarding FAIL


[re: BLaZiNgSPEED] [link to this post]
 
From your screen shot you are attempting to add an inbound rule for any and all ports

By default doesn't the netgear have an active Inbound rule to block all services to any LAN users - Is this where your error occurs this default inbound rule cannot be edited as far as I am aware is this resulting in your error?

can we ask again whether you have tried to define custom services this is not the same as the firewall rules inbound/outbound in the router web page...

on the left hand side either under security or advanced there should be a services button this is where you add a service with port range TCP/UDP/BOTH (so you can define your own port range to forward or block) these services once created will then appear under the firewall rules.

The router has various built in services with can be added to the firewall inbound/outbound rules and if the services you attempt to add conflict with those already available or in use by devices on your network you will receive an error.

Can you confirm whether you are just selecting the pre configured available services when adding firewall rules inbound/outbound, or creating your own services in which you will be prompted for service name, start port, end port or port range and whether it is TCP/UDP or Both protocols.

I will admit that I ran into a similar issue with another netgear product after a firwmare update but this was only due to the UI being changed regarding how firewall and port forwarding was accessed edited in the UI of the web interface.

I was also going to link to smilo's post on the netgear community forums ^^

NO idea if this is clear but I am stuck posting on my phone handset...
Administrator MrSaffron
(staff) Mon 02-Nov-15 16:15:15
Print Post

Re: Trouble with NETGEAR Router DGN2200 Port Forwarding FAIL


[re: BLaZiNgSPEED] [link to this post]
 
If I try to set Any(ALL) for the other 2 static ip addresses the Failure message will appear again


You can only set a rule like that up once, since one you forward a port or collection of ports to one device you cannot forward the same TCP port to a second device.

i.e. you can only forward TCP port 1234 to one device at a time, so if you are running two devices that require a fully open TCP port 1234 on the inbound direction then its not possible.

The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
Standard User BLaZiNgSPEED
(regular) Mon 02-Nov-15 16:41:19
Print Post

Re: Trouble with NETGEAR Router DGN2200 Port Forwarding FAIL


[re: MrSaffron] [link to this post]
 
In reply to a post by AgedDex:
From your screen shot you are attempting to add an inbound rule for any and all ports

By default doesn't the netgear have an active Inbound rule to block all services to any LAN users - Is this where your error occurs this default inbound rule cannot be edited as far as I am aware is this resulting in your error?

can we ask again whether you have tried to define custom services this is not the same as the firewall rules inbound/outbound in the router web page...

on the left hand side either under security or advanced there should be a services button this is where you add a service with port range TCP/UDP/BOTH (so you can define your own port range to forward or block) these services once created will then appear under the firewall rules.

The router has various built in services with can be added to the firewall inbound/outbound rules and if the services you attempt to add conflict with those already available or in use by devices on your network you will receive an error.

Can you confirm whether you are just selecting the pre configured available services when adding firewall rules inbound/outbound, or creating your own services in which you will be prompted for service name, start port, end port or port range and whether it is TCP/UDP or Both protocols.

I will admit that I ran into a similar issue with another netgear product after a firwmare update but this was only due to the UI being changed regarding how firewall and port forwarding was accessed edited in the UI of the web interface.

I was also going to link to smilo's post on the netgear community forums ^^

NO idea if this is clear but I am stuck posting on my phone handset...

Yes I have tried with a Custom created service and this issue was still happening. It also happens with the list of pre configured available services from Firewall Rules.

However, Rebooting the router from Diagnostics and immediately Port Forwarding solves the problem! Now all ports are open as normal for my PC device.

In reply to a post by MrSaffron:
If I try to set Any(ALL) for the other 2 static ip addresses the Failure message will appear again


You can only set a rule like that up once, since one you forward a port or collection of ports to one device you cannot forward the same TCP port to a second device.

i.e. you can only forward TCP port 1234 to one device at a time, so if you are running two devices that require a fully open TCP port 1234 on the inbound direction then its not possible.

So what would be the solution if I wanted to open all ports for my other computer? I have another custom built Gaming PC that I built for my dad a few weeks ago which is more powerful than my own. I would like to have the ports opened for his PC as well so that if I can play some of the more intense games that won't run as well on my PC I would like to have the option to play them on his PC without having to worry about the ports being blocked.

Is there anyway I can do that without having to reconfigure port forwarding to that PC device?
Standard User ian72
(eat-sleep-adslguide) Mon 02-Nov-15 16:45:15
Print Post

Re: Trouble with NETGEAR Router DGN2200 Port Forwarding FAIL


[re: BLaZiNgSPEED] [link to this post]
 
You can open all ports outgoing for as many devices as you want.

However, incoming is "port forwarding". That means a device outside your network is opening the connection to the device inside your network. However, as you only have one public IP you have to choose to forward each port to a specific device (otherwise how does it know which internal device to forward to).

Therefore if you forward all ports to PC A there is no way to also forward all ports to PC B as there is no way to differentiate between the 2 devices from the outside world.

You either need an external IP for each device (ie get static IPs from the ISP) or you need to forward a range of ports to one device and a different range to the other.
Pages in this thread: 1 | [2] | (show all)   Print Thread

Jump to