General Discussion
  >> General Broadband Chatter


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User TimJ
(committed) Fri 18-Dec-20 22:43:31
Print Post

New FTTP line TBB speed test and some othe sites time out


[link to this post]
 
This afternoon we had FTTP from Airband installed. It has been a long wait as during Aug 2019 they promised it by Christmas, at the time we though that was 6 months away not 18!

Now when I try to do a TBB speed test the page come up quickly but then stalls for ~30secs and gives a message labs.thinkbroadband.com took too long to respond. rather than coming u with the provider/Postcode page.

Similarly comms-express.com also fails for the same reason.

Going back to our 4G connection via 3 both works fine.

I am also handicapped as I don't have the password to login to the router a Genexis Pore-ED500.

I have raised a support ticket but wondered if there were any ideas here.

Tim
Administrator MrSaffron
(staff) Fri 18-Dec-20 23:32:32
Print Post

Re: New FTTP line TBB speed test and some othe sites time ou


[re: TimJ] [link to this post]
 
If you goto https://labs.thinkbroadband.com/speedtest does that page load and the test run?

Assumption in asking you to go direct to test, may be something is blocking the test loading in an iframe with the usual link https://www.thinkbroadband.com/speedtest

The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
Standard User TimJ
(committed) Fri 18-Dec-20 23:51:56
Print Post

Re: New FTTP line TBB speed test and some othe sites time ou


[re: MrSaffron] [link to this post]
 
Thanks for your reply

No it still times out after around 30 secs.


Register (or login) on our website and you will not see this ad.

Standard User TimJ
(committed) Sat 19-Dec-20 00:08:59
Print Post

Re: New FTTP line TBB speed test and some othe sites time ou


[re: MrSaffron] [link to this post]
 
It looks like a TLS issue
via airband
[email protected]:~$ curl -v https://labs.thinkbroadband.com/speedtest
* Trying 2a02:68:1:1000::12...
* TCP_NODELAY set
* Connected to labs.thinkbroadband.com (2a02:68:1:1000::12) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
* CAfile: /etc/ssl/certs/ca-certificates.crt
CApath: /etc/ssl/certs
* TLSv1.3 (OUT), TLS handshake, Client hello (1):

It then hangs

Via Three
[email protected]:~$ curl -v https://labs.thinkbroadband.com/speedtest
* Trying 80.249.106.133...
* TCP_NODELAY set
* Connected to labs.thinkbroadband.com (80.249.106.133) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
* CAfile: /etc/ssl/certs/ca-certificates.crt
CApath: /etc/ssl/certs
* TLSv1.3 (OUT), TLS handshake, Client hello (1):
* TLSv1.3 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (IN), TLS handshake, Server key exchange (12):
* TLSv1.2 (IN), TLS handshake, Server finished (14):
* TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
* TLSv1.2 (OUT), TLS change cipher, Client hello (1):
* TLSv1.2 (OUT), TLS handshake, Finished (20):
* TLSv1.2 (IN), TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES128-GCM-SHA256

Continues to a successful download.
Administrator MrSaffron
(staff) Sat 19-Dec-20 09:47:13
Print Post

Re: New FTTP line TBB speed test and some othe sites time ou


[re: TimJ] [link to this post]
 
Try turning off IPv6 on the client device. This seems to be a difference

IPv6 is working for plenty of people so maybe something quirky with the ISP

The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
Standard User TimJ
(committed) Sat 19-Dec-20 11:18:27
Print Post

Re: New FTTP line TBB speed test and some othe sites time ou


[re: MrSaffron] [link to this post]
 
Thanks

That fixed it. This is my 1st experience of IPV6, I am not sure what the implications of turning it off.

From the results it looks as if I have incorrectly been put on their 250/75 package rather than the 150/60 that I am paying for.
speedtest
Administrator MrSaffron
(staff) Sat 19-Dec-20 12:34:42
Print Post

Re: New FTTP line TBB speed test and some othe sites time ou


[re: TimJ] [link to this post]
 
IPv6 should be transparent and as its working for others

The author of the above post is a thinkbroadband staff member. It may not constitute an official statement on behalf of thinkbroadband.
  Print Thread

Jump to