General Discussion
  >> Mobile Broadband (3G, 4G, 5G etc)


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | (show all)   Print Thread
Standard User richi
(member) Tue 08-Sep-20 16:24:53
Print Post

Three is finally working properly OMFG.


[link to this post]
 
After months of frustrating random timeouts/retries when loading pages, Three seems to have fixed it (at least from where I sit).

Holy mother of dog.

Dunno if this is network-wide, or confined to certain masts: They sent me an SMS a few days ago, saying they'd be working on my mast (I connect to cell 3143426 / eNB 12279). Things were pretty ropey over the weekend, but from Monday morning onwards, I've not noticed a single timeout/retry loading a web page.

One thing I did notice—and I think this is a change—is the true MTU has dropped to 1400. So if you have, say, 1440 or 1500 set, large packets will fragment. Best to drop it down to 1400: on my B535 it's at /html/content.html#mobileconnection or you can set it from the API tab in LTE H-Monitor.

70/30 Three unlimited SIMO, replacing 3 km ADSL line.
Previously: BT ISDN, Nildram, Plusnet, 186k, EFH, Be*, Plusnet (again), Pulse8, Sky, Plusnet Business, TalkTalk Retail.
Standard User richi
(member) Tue 08-Sep-20 16:31:26
Print Post

Re: Three is finally working properly OMFG.


[re: richi] [link to this post]
 
(this is using the default APN of 3internet)

70/30 Three unlimited SIMO, replacing 3 km ADSL line.
Previously: BT ISDN, Nildram, Plusnet, 186k, EFH, Be*, Plusnet (again), Pulse8, Sky, Plusnet Business, TalkTalk Retail.
Standard User woodmass14
(committed) Tue 08-Sep-20 22:13:37
Print Post

Re: Three is finally working properly OMFG.


[re: richi] [link to this post]
 
I don't want to jinx it but it appears alright for me currently too. Snappy responses of most websites i visit, including thinkbroadband. Before i'd have to wait 30 plus seconds or constantly refresh until it popped up. Could not view forums on threaded view without waiting either. Was just too time consuming. I just hope its permanent...Please be permanent smile


Register (or login) on our website and you will not see this ad.

Standard User ukhardy07
(knowledge is power) Tue 08-Sep-20 23:29:05
Print Post

Re: Three is finally working properly OMFG.


[re: woodmass14] [link to this post]
 
Is it really that bad, 30 seconds to load a basic website?!

Surely 3 customers would be complaining a hell of a lot if this was universal?
Standard User woodmass14
(committed) Wed 09-Sep-20 00:47:01
Print Post

Re: Three is finally working properly OMFG.


[re: ukhardy07] [link to this post]
 
It was, yes. Happened with ispreview too. Didn't happen with all websites though. Probably the reason why everyone using three isn't complaining about it. I don't think their average customer is browsing thinkbroadband or ispreview. Most social media sites seem to be fine, or were for me. Youtube, netflix and amazon video were all working for me when it was happening as well. If they didn't i'm sure it would make national news, or fixed long before it made the news. I wish i could be more specific to the sites i had problems with but it become so normal that i stopped paying attention.

Though i did have problems with some games. Would try to connect to game servers and would fail multiple times before connecting. Sometimes having to quit the application to rinse and repeat until i connected. Maybe some folks just put it down to gaming on a 4G connection and didn't bother complaining. And complaining to Three was useless. They'd allow you to cancel the contract, as long as they got their router back

Just to add. I have no idea if this was universal. I know many others were/are facing the same issue. Perhaps its an issue for a small number of customers and that's the reason its taking/took so long to fix. No idea what the cause was/is

Edited by woodmass14 (Wed 09-Sep-20 01:17:23)

Standard User richi
(member) Wed 09-Sep-20 12:57:56
Print Post

Re: Three is finally working properly OMFG.


[re: ukhardy07] [link to this post]
 
Yeah, I found it would happen randomly across any website. It looked like the initial TCP or TLS negotiation sometimes got messed up. The Chrome tab would sit there for about 20 seconds, time out and immediately automatically retry, which worked.

One likely guess is that something was fragmenting then re-assembling packets at a layer below IP. But it occasionally got it wrong, causing this problem. The fact that the MTU seems to have changed at the same time as the problem going away is … suspicious.

70/30 Three unlimited SIMO, replacing 3 km ADSL line.
Previously: BT ISDN, Nildram, Plusnet, 186k, EFH, Be*, Plusnet (again), Pulse8, Sky, Plusnet Business, TalkTalk Retail.

Edited by richi (Wed 09-Sep-20 12:59:29)

Standard User andynormancx
(member) Wed 09-Sep-20 14:33:39
Print Post

Re: Three is finally working properly OMFG.


[re: richi] [link to this post]
 
In reply to a post by richi:
Yeah, I found it would happen randomly across any website. It looked like the initial TCP or TLS negotiation sometimes got messed up. The Chrome tab would sit there for about 20 seconds, time out and immediately automatically retry, which worked.


Same here when I was still on Three, it impacted sites pretty much randomly (though with sites that make more individual TCP/TLS connections being more likely to be affected).
Standard User buggerlugs
(member) Wed 09-Sep-20 14:50:54
Print Post

Re: Three is finally working properly OMFG.


[re: andynormancx] [link to this post]
 
You can get around the page hanging issue by using cloudflare warp beta on your pc.
Standard User RobertoS
(elder) Wed 09-Sep-20 19:18:55
Print Post

Re: Three is finally working properly OMFG.


[re: buggerlugs] [link to this post]
 
Interestingly, all the content on these forums is delivered through Cloudfare.

__________________________________________________________
Sovereignty Means Sovereignty

My broadband basic info/help site - www.robertos.me.uk. Domains, sites and mail hosting - Tsohost & Ionos.
Connections: OnePlus 8 Pro max 165Mbps down, 24Mbps up on Three, and B311 4G, tbb tests normally 35-45Mpbs down, 65Mbps off-peak, 9-24 up.
========================
To argue with mindless bigots is foolish.
Standard User jchamier
(eat-sleep-adslguide) Wed 09-Sep-20 19:23:50
Print Post

Re: Three is finally working properly OMFG.


[re: RobertoS] [link to this post]
 
In reply to a post by RobertoS:
Interestingly, all the content on these forums is delivered through Cloudfare.
I gather Cloudflare have some really high percentage of internet sites, over 50%, now protected on their platform.

The Warp service is about DNS encryption, there are other choices. E.g. you can use DNS-over-HTTPS in many browsers, and some routers (e.g. my ASUS) offer DNS over TLS. If Three's problem was broken DNS, then bypassing the ISP makes sense, which is what Cloudflare Warp would do.

Services such as Quad 9 also support DNS over TLS and DNS-over-HTTPS.

(I'm a fan of DNS over TLS, and dislike DNS over HTTPS, as DNS should be handled by the operating system or local network hardware, not the application layer).

20 years of broadband connectivity since 1999 trial - Live BQM
Pages in this thread: 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | (show all)   Print Thread

Jump to