Technical Discussion
  >> Web Design / HTML / Web hosting Forum


Register (or login) on our website and you will not see this ad.


  Print Thread
Standard User charlestown
(regular) Fri 16-Apr-21 21:31:29
Print Post

FTP upload errors with new TP-Link router


[link to this post]
 
Last week I purchased a new TP-Link AC2300 router along with a Draytek modem to replace my old Vodafone router, since I plan on changing ISP shortly. It works well generally, however I have been plagued by FTP upload issues leading to time out messages. Effectively I couldn't upload changes reliably.

After hours of testing I went back to my old router not long ago and it all worked perfectly. It seems I am not the only one having issues https://community.tp-link.com/en/home/forum/topic/15...

Does anybody have an idea why this might be happening? If I cannot fix it this weekend I shall have to send it back and look for an alternative.
Standard User charlestown
(regular) Sat 17-Apr-21 13:48:36
Print Post

Re: FTP upload errors with new TP-Link router


[re: charlestown] [link to this post]
 
I found the cause of this problem in case it happens to anybody else. It's a feature inside the router's built in antivirus software that is enabled by default. When the intrusion prevention system is on it becomes just about impossible to upload or delete content from the server via FTP. When disabled it all works normally.
Standard User Pipexer
(eat-sleep-adslguide) Sat 17-Apr-21 14:47:37
Print Post

Re: FTP upload errors with new TP-Link router


[re: charlestown] [link to this post]
 
Which takes me back to the point in your other thread - beyond the "basic" security features provided by home routers, all those additional "security" options they claim to offer cause more problems than they solve. It's snake oil to sell routers to people who don't need them.

Andrews & Arnold Home ::1 on Draytek 2862ac - Why settle for inferior?


Register (or login) on our website and you will not see this ad.

Standard User charlestown
(regular) Sat 17-Apr-21 15:54:50
Print Post

Re: FTP upload errors with new TP-Link router


[re: Pipexer] [link to this post]
 
You may well be right. I took the opportunity to turn off all the ALG options while I was there that looked like an open door and all enabled by default.
Standard User charlestown
(regular) Sat 17-Apr-21 16:19:21
Print Post

Re: FTP upload errors with new TP-Link router


[re: charlestown] [link to this post]
 
An afterthought, but I also changed the custom DNS to use Quad9 rather than the ones supplied by my ISP. At one point I used CloudFlare but found it was taking ages for caches to clear to verify updated sites. CloudFlare actually has a site for flushing their cache, suggesting they are aware of the issue.
  Print Thread

Jump to