User comments on ISPs
  >> Wireless Broadband ISPs (not wireless ADSL routers)

Register (or login) on our website and you will not see this ad.

  Print Thread
Standard User gilbertcat1
(newbie) Sat 11-Feb-12 18:01:59
Print Post

Incomplete loading of pages

[link to this post]
I have recently changed from Virgin adsl to wireless broadband. Pleased with speed but some webpages will not completely load. ISP has provided a wireless router - Edimax BR-6428nS. I suspect the router as if I take my laptop to another house with all pages load. So far iSP not very helpful.

I use an an Apple Imac and macbook OS 10.58
Please has anyone similar experience and helpful suggestions?
Standard User kijoma
(committed) Sun 12-Feb-12 12:12:15
Print Post

Re: Incomplete loading of pages

[re: gilbertcat1] [link to this post]

This sounds like a DNS problem. This is an issue we have seen before and it may mean they are using a certain manufacturer of infrastructure router that has a bug with its DNS server.

It caused us a lot of headaches until we discovered it and worked around it. it tends to affect yahoo, amazon , some google sites etc..

A workaround there would be to set your DNS servers on your MAC to say and instead of the ISP provided ones.

If that does not resolve it then they may be using a thing called PPPoE and the issue may relate to MTU settings as this can also cause this effect.

Either way you need to poke Kencomp , but at least if you discover it is DNS then you are armed with that fact.


Bill Lewis - MD
Kijoma Broadband - (Division of Kijoma Solutions Ltd)
Fixed wireless ISP - ISPA/CISAS/RIPE members
My Broadband Speed Test
Standard User gilbertcat1
(newbie) Tue 14-Feb-12 16:41:26
Print Post

Re: Incomplete loading of pages

[re: kijoma] [link to this post]
Thank you for your comments. I am beginning to learn about technical settings etc. so please forgive any ignorance on my part.

The DNS setting on the Mac is greyed out and reads 192.168.2.

I believe Kencomp is using PPPoE and say in an emailed reply to me that my Mac is misconfigured and I should rest the MTU setting.

"as a default we use an MTU of 1472 to allow for transit encapsulation, so you should therefore use a figure of 1432 or lower (mss is typically 40 bytes below MTU/MRU)"

I reset the MTU to 1432 (and 1422, 1452) without any change - same websites will not fully load.

I am confused in that my Macs worked fine with Virgin adsl and also the Macbook is fine when connected via a friend's Wifi.

I have reported to Kencomp and await further advice.

Register (or login) on our website and you will not see this ad.

(Unregistered)Tue 21-Feb-12 09:23:26
Print Post

Re: Incomplete loading of pages

[re: gilbertcat1] [link to this post]
Further development.

The ISP said that they are certain that the configuration of Macs is the problem. I found a reference to this on another forum where it was suggested a change to DNS in the Mac's network settings - and .

I have done this and all pages are now loading. I do not understand but for now all ok.
Standard User 5km
(knowledge is power) Tue 21-Feb-12 20:23:43
Print Post

Re: Incomplete loading of pages

[re: Anonymous] [link to this post]
So you're using OpenDNS and not the ISP's DNS server. Do they even have their own DNS servers?

You could manually set OpenDNS on the router if you have one and have access to it then you don't need to change the DNS settings on each computer/device.

O2 Broadband Premium LLU
Now on twitter @timmay2
  Print Thread

Jump to