User comments on ISPs
  >> Zen Internet


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | 3 | 4 | 5 | [6] | 7 | 8 | 9 | >> (show all)   Print Thread
Standard User techguy
(experienced) Fri 21-Aug-15 19:46:44
Print Post

Re: IPv6 trial


[re: AndyS] [link to this post]
 
How did you get this enabled as mailed their hello e-mail address yesterday and haven't heard anything back as yet.

Virgin (ADSL) => Namesco => Newnet => O2 => Plusnet => Zen => Newnet => Zen => Freeola => Vivaciti (using O2 Wholesale DSL) => Xilo (C&W Wholesale) => Xilo (O2 Wholesale) => Xilo (TT Wholesale due to O2 Wholesale closure) => Zen LLU
Router: Billion 8800NL
Note: I don't lay turf for anyone. astro or otherwise, all views and opinions expressed are my own based on experience.
Standard User ZenUserJP
(regular) Sat 22-Aug-15 00:20:49
Print Post

Re: IPv6 trial


[re: techguy] [link to this post]
 
This is what I have, does anyone know what's going on?

I have an address under "Default IPv6 Gateway / IPv6 Address" in summary

this is my Ipv6 bit

http://prntscr.com/87f8kd

this is on my mac

http://prntscr.com/87f8lf

Edit I have done a firmware upgrade and it detected IPv6 right off the bat without the autoconfig bit needing doing but the MAC didn't have the address untill I did the advertisment stuff

nothing works!

Edited by ZenUserJP (Sat 22-Aug-15 01:23:47)

Standard User mixt
(fountain of knowledge) Sat 22-Aug-15 08:26:45
Print Post

Re: IPv6 trial


[re: ZenUserJP] [link to this post]
 
Try changing your static LAN IPv6 address configuration from a /48 to a /64 prefix length. The normal way this works is that each LAN interface should use a /64 prefix from the /48 Zen delegate you (allowing you to have 65536 different /64s). The reason for this is that other services, like radvd, which advertise this /64 to the rest of your LAN (so that devices can auto-configure themselves etc) expect to use the remaining 64 bits in a specific way to manage stateless configuration. Read this to get an idea of why this is the case: http://superuser.com/questions/662851/radvd-wont-acc... - it involves many RFCs that were finalised years ago now.

This should work, and your MAC should be getting an address under 2a02:8010:8001:0::/64 (the first /64 of your /48).

Zen Unlimited Fibre + Native IPv6 (Trial)
Automated Hourly HTTPx6 TBB Speed Tests (3xIPv4+3xIPv6)
Previous ISPs » aaisp.net (40/10Mb FTTC) | Virgin Media (50Mb/Cable) | Be* Un Limited (ADSL2+) | Zen (ADSL)
Download Maximiser | BIND GeoDNS | Are you being blÝcked?


Register (or login) on our website and you will not see this ad.

Standard User tehdan
(newbie) Sat 22-Aug-15 10:47:52
Print Post

Re: IPv6 trial *DELETED*


[re: mixt] [link to this post]
 
Post deleted by tehdan
Standard User AdrianPH
(learned) Sat 22-Aug-15 12:02:43
Print Post

Re: IPv6 trial


[re: techguy] [link to this post]
 
https://forum.zen.co.uk/forums/permalink/50813/50601...
Standard User ZenUserJP
(regular) Sat 22-Aug-15 14:52:16
Print Post

Re: IPv6 trial


[re: mixt] [link to this post]
 
Thanks for your reply and help.

Here is the current Router status http://prntscr.com/87lelo

SO I did a clean setup, checked IPv6 and the Billion configured and picked it up right away. I then did this (is it right?) http://prntscr.com/87le3q . I also now get this. http://prntscr.com/87le7g but sites like http://test-ipv6.com/ fail telling me I am on IPv4. I've done a restart with current settings.

The mac shows the router as being located at e80::6203:47ff:fe12:285b but I am told even with /64 on the end it's invalid when I try this.

I am noticing slower browsing even when I use Google's IPv6 DNS so I assume something, somewhere is working

Edited by ZenUserJP (Sat 22-Aug-15 14:54:43)

Standard User mixt
(fountain of knowledge) Sat 22-Aug-15 15:51:05
Print Post

Re: IPv6 trial


[re: ZenUserJP] [link to this post]
 
I think you misunderstood me - I'll clarify again.

Zen give you two prefixes - a /64 and a /48. The /64 is for the WAN side, and used purely for the purpose of allowing your router to auto-configure a random IPv6 address under this /64 assignment, on its WAN interface. Looking at your screen shots, it has already done this successfully.

Now the next part.

The /48 they give you is for use on the LAN side. It is routed via the /64 IP address that the router auto-configures itself with on its WAN interface. But, you need to tell your router what /64 prefix (and there are 2^(64-48) = 2^16 = 65536 different /64 prefixes to choose from) it should use for the LAN interface. So, set the "Static LAN IPv6 Address Configuration - Interface Address / Prefix Length" to be:

2a02:8010:8001::/64

(which is the same as 2a02:8010:8001:0::/64) - the 0 is the very first /64 prefix you can use from 2a02:8010:8001::/48, which they've delegated to you.

You've currently set the "Interface Address / Prefix Length" field to the /64 ND (Neighbour Discovery) prefix Zen gave you (2a02:8011:d008:1::/64) which is incorrect. This may still work, but it is not the way Zen intended this /64 to be used, in a routed setup.

Zen Unlimited Fibre + Native IPv6 (Trial)
Automated Hourly HTTPx6 TBB Speed Tests (3xIPv4+3xIPv6)
Previous ISPs » aaisp.net (40/10Mb FTTC) | Virgin Media (50Mb/Cable) | Be* Un Limited (ADSL2+) | Zen (ADSL)
Download Maximiser | BIND GeoDNS | Are you being blÝcked?

Edited by mixt (Sat 22-Aug-15 16:09:45)

Standard User ZenUserJP
(member) Sat 22-Aug-15 16:45:45
Print Post

Re: IPv6 trial


[re: mixt] [link to this post]
 
Thanks and sorry that I did.

Okay I have set it to that and restarted and it's still going to ipv4 when i try ipv6 sites so I will call Billion Monday Morning and get the settings checked over.
Standard User Geordish
(regular) Sat 22-Aug-15 17:20:48
Print Post

Re: IPv6 trial


[re: ZenUserJP] [link to this post]
 
Try not configuring an IPv6 address on your LAN at all. It should be clever enough to sort that bit out on its own.
Standard User rhetherington
(committed) Sat 22-Aug-15 17:33:41
Print Post

Re: IPv6 trial


[re: Geordish] [link to this post]
 
Check the actual prefixes in the email that Zen sent you when they set up IPv6 for your account. You've posted multiple screen shots set up with different prefixes, so i'm unsure what your actual /48 is.

Ignore the ND Prefix line, since your router is handling that.

Copy and paste the Delegated Prefix into the "Interface Address / Prefix Length" changing the end from /48 to /64.

You don't need to meddle with settings on the Mac (you may want to restart it, so it doesn't keep addresses from the old prefix). I'm on a Hackintosh running Mavericks and it all just works fine.

Once the Mac gets a new IPv6 address open up a terminal and do:
Text
1
ping6 google.com

and you should see a response. Proceed with any IPv6 tests you wanted to do,
Pages in this thread: 1 | 2 | 3 | 4 | 5 | [6] | 7 | 8 | 9 | >> (show all)   Print Thread

Jump to