General Discussion
  >> General Broadband Chatter


Register (or login) on our website and you will not see this ad.


Pages in this thread: 1 | 2 | 3 | [4] | 5 | (show all)   Print Thread
Standard User gc1
(regular) Fri 07-Aug-20 11:06:38
Print Post

Re: Extending BTWifi


[re: thinkbfan] [link to this post]
 
In reply to a post by thinkbfan:
That may explain what is happening here, that the local BT subscriber has a spike request (e.g. kids load up netflix) and rather than lower my speed they boot me off.


I don't think it works that way. When I tried simultaneous speed tests on my own BT router from one device and BTwifi to my own BT router from another device both worked OK, but only a minor portion of the available bandwidth went to the BTwifi connection (as it should).

Random disconnections do happen. You don't always get the full 3 hours. But I think this is the CGNAT gateways deciding to disconnect somebody when the total number of users gets too high to free up a slot for new connections (this is just a guess). Also there is a relatively short idle timeout so inactive users are disconnected. I don't think I have ever experienced a connection to drop after only 10 seconds.
Standard User thinkbfan
(newbie) Fri 07-Aug-20 11:08:45
Print Post

Re: Extending BTWifi


[re: kitcat] [link to this post]
 
Yes, in fact some routers only work that way, for example linksys.

I tried using 5.0 to pick up and 2.4 to distribute, it did not seem to improve things.

On my router I can either lock the pick up to 5.0 or 2.4 or I can say it is preferred and let the Router decide what is best.

To rule out my router dropping it I tried saying only 5.0 (which was the best pickup) but still create 5.0 and 2.0 client SSID's which both work.

What is bizarre, is that sometimes one or the other (2.4 or 5.0) will not connect, at other times for example this morning, the 2.4 will connect perfectly on the iphone but not on the Ipad and the 5.0 would not connect either for the Ipad but both 2.4 & 5.0 would connect with a laptop.

With WDS on the TPlin and on documentation I have seen on other routers, it is a condition that the repeated network uses the same channel, I think the Buffalo does not give you the choice, it just does it, while on the TPlink it gives a warning and offers you the prompt.

I am aware of wireless channel conflicts but I do not think they are are problem here, I have been using software on my laptop to look at what they are using and there are not that many in range and few using the same channel.

I was in LA once and I really understood what conflict was, I was there for three months on a project and the place I was stating was just a condo in a normal street, but I could see 50 SSID's because people were buying these super powerful routers and blasting their wifi and making things worse.

With the Buffalo it does not bridge the Lan Ports into the WDS network it creates, it has a switch for AP or WB, in Wireless Bridge mode the Lan ports have no connection.

However, I have been thinking along the same lines, I saw a post suggesting one can use Windows to bridge a network, I was thinking I might be able to then connect that via a wired connection to the Buffalo in AP mode or the TPlink.

In the past I have used two TPlinks to extend network around my home, first with a wired connection for about 10m and then with a wireless bridge, sadly I can't use TPlink in my current scenario because the WDS implementation requires disabling DHCP and I would need to know what subnet the BTwifi was going to use and even then it would fail after about 30 days.

I would love it if I could get ethernet working, it is one of the considerations for the routers I am looking at.

Yesterday I bought a ROKU 4k device it is a tiny HDMI stick with a cable for USB for power but also acts as an antenna. Not only can this pick up the BTwifi at varying signal strength but is holds the connection solidly for 2 hours, at which time I can log back in.

Last night when the 2 hour session limit expired I tried it on one of my internal SSID's with the boosted signal, it managed to connect and AGAIN held the connection solidly for 2 hours. However, later it was problematic to get a signal on any network for around an hour.

Unfortunately I am not that keen on TV, I would not mind if one device worked solidly for the time I was using it, whether it be iPhone, iPad or Laptop.
Standard User thinkbfan
(newbie) Fri 07-Aug-20 11:18:03
Print Post

Re: Extending BTWifi


[re: j0hn83] [link to this post]
 
In reply to a post by j0hn83:
I can confirm is possible also.

I had no FTTC after ceasing my line when trying to switch between my ECI cabinet and the newly installed Huawei cabinet.

I went about 7-8 weeks on the neighbours BTWifi hotspot, picking up the signal on a TP-Link WAP and then repeating it around the house for all our devices.
It worked flawlessly, getting around 9Mb/s most of the day.

I tried this last week on my Asus RT-AC68U without success as I was getting moaned at for taking the connection down.

I plan on getting this working this week as my Virgin goes off on the 9th and my FTTP doesn't go live till the 12th.
I want to pick up the neighbours BTWifi again and run off that for 3 days.
Fortunately BT enable access to their WiFi the day your order is placed which is very handy.


Thanks I knew that others would be doing this, which I why I want to see it through and figure it out, so next time someone else needs it to work they can get it going.

I would be interested to know which TP-Link WAP you used, was it a repeater, a router configured with WDS or what, I have several TP-link devices but they all had this need in WDS to disable DHCP. Maybe their repeaters do not do this.

Do you no longer have your TP-link device, hence used ASUS?

The last time I needed this the Buffalo worked flawlessly and gave 8mb/9mb with so many options to change and only changing one at a time, then doing a factory reset it is tedious.


Register (or login) on our website and you will not see this ad.

Standard User j0hn83
(fountain of knowledge) Fri 07-Aug-20 12:37:09
Print Post

Re: Extending BTWifi


[re: thinkbfan] [link to this post]
 
TP-LINK TL-WA801ND

I bought it for this specific task.
Setup was a repeater, specifically the TP-link menu was "universal repeater" and not a WDS repeater.
Standard User thinkbfan
(newbie) Sun 30-Aug-20 21:37:51
Print Post

Re: Extending BTWifi


[re: gc1] [link to this post]
 
In reply to a post by gc1:
I use two routers for this, one as just a client router to act as the BTwifi client, with an Ethernet connection to a second router some distance away to provide my access point for local devices. This way the transmitter from one will not swamp the receive amp of the other.

I would suggest starting with a router configured as just a wifi client (not a repeater) and connect by wired Ethernet to a PC and see if you can get it working that way.

The client router does network address translation so it doesn't matter how many devices are connected locally they all come through to the BTwifi access point as one MAC address and one IPv4 address.

I use OpenWRT in the client router which is very configurable. But that is an even steeper learning curve than DD-WRT so you may not want to go down that route,

BTwifi signals from neighbours will be weak, you need to make sure you get at least 20dB signal to noise ratio for the connection to stay up and remain stable. An external directional antenna may be necessary. I use a 19dBi flat plate antenna and only just manage to get around a 22dB SNR. If you are in a flat rather than a detached house this won't be such a problem.

TP-link routers are usually pretty good for wireless sensitivity, I doubt if a different model would improve the situation. I use an old TL-WR1043ND and that works well as a client for weak signals even with the stock short vertical stick antennas.

I don't understand why you would need to disable DHCP on the router. That should only apply for it's local LAN and any wifi access point it provides. It's wifi client connecting the BTwifi access point will be a DHCP client to pick up the CGNAT address (100.x.x.x etc.) that the latter provides.

For speed the service is rate limited to 10Mbps send and receive. In practice somewhat less (e.g. 5 to 10 Mbps) should be achievable provided you are the only BTwifi client on that access point and the wifi signal strength is good and you neighbour has a fast (VDSL or FTTP) connection. Sometimes the CGNAT gateway is heavily loaded and the speed is really poor. Then disconnecting the wifi client and reconnecting gets a different CGNAT client address through a less loaded gateway and the speed improves.


I tried a TP-Link router with DD-WRT configured as a client mode (not client bridge) but I could not get it it to work.

I easily get over 30dB in fact two are at 53 & one is at 31

The disabling of DHCP is advice from TP-Link for WDS, they do not have client mode on most of their firmware except products designed as dedicated wireless access points, I tried one of those but it did not work. Most of their documentation is about client bridge config and they suggest disabling DHCP so it picks it up from the bridged router. This will never work for BTWIFI, but it does if you are extending a router you control because you can tell DCHP relay to point to the host router.

As you say BTWIFI use the 100.x.x.x subnet, configured as a class B subnet. I seem to get a different one everytime I connect, I noticed sometimes the lease if 5 minutes and sometimes 30m but these do not explain the loss of connection which can be seconds after I re-login.

The only common factors I have noticed about the 100.x.x.x network is that it creates are that the default gateway and DHCP server are always at 100.x.0.1 of the subnet used and that the DNS are always 192.168.22.22 and 192.168.22.23 as shown below

IPv4 Address. . . . . . . . . . . : 100.96.55.55
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Lease Obtained. . . . . . . . . . : 01 August 2020 13:16:43
Lease Expires . . . . . . . . . . : 01 August 2020 13:46:47
Default Gateway . . . . . . . . . : 100.96.0.1
DHCP Server . . . . . . . . . . . : 100.96.0.1
DNS Servers . . . . . . . . . . . : 192.168.22.22
192.168.22.23

but if I try to Trace Router to the DNS servers I get

Tracing route to 192.168.23.23 over a maximum of 30 hops

1 65 ms 22 ms 23 ms 100.96.0.1
2 * * * Request timed out.

then request timed out

29 times.

I get a different subnet every time I connect if connect to BTwifi on laptop, I can't get WAN on TP-Link firmware, on DD-WRT I can get a static one but no internet connection on the router.

Ironically I do have an old V1 version of an TL-WR1043ND, DD-WRT do not support it but Open-WRT do, I do not know how hard it it but I downloaded the firmware files for this router.

I wonder if you can give some pointers on the configuration you used and any important settings, or better still could you do be backup of your config and PM me a cloud link for the bin file (setting default passwords before you save).

Now BT have rewritten the login page for BTWifi which is even more irritating because it uses a drop down field and BT Broadband is not the default option so it makes logging in even more tedious.

This has become a bit of a mission for me, I can still get it working on my old buffalo but it is SO unreliable despite it working solidly a few years ago.

Any help you can offer would be appreciated.

Edited by thinkbfan (Sun 30-Aug-20 21:44:11)

Standard User JonRennie
(knowledge is power) Mon 31-Aug-20 09:18:06
Print Post

Re: Extending BTWifi


[re: thinkbfan] [link to this post]
 
Those DNS servers are never going to work - they are in one of the private, non-routable address ranges (defined in RFC1918).

wink Comms is hard wink
Standard User thinkbfan
(newbie) Mon 31-Aug-20 12:07:31
Print Post

Re: Extending BTWifi


[re: JonRennie] [link to this post]
 
In reply to a post by JonRennie:
Those DNS servers are never going to work - they are in one of the private, non-routable address ranges (defined in RFC1918).


Well clearly BT (like some other organisations) feel that their network is private.

Google for example uses the 10.x.x.x subnet for Gmail

Don't blame me for BT's config, I am merely reporting what is returned.

If you actually have anything that may help the problem I am struggling with it would be a welcome comment.
Standard User Oliver341
(eat-sleep-adslguide) Mon 31-Aug-20 14:06:00
Print Post

Re: Extending BTWifi


[re: thinkbfan] [link to this post]
 
Set dns on your device to 8.8.8.8

Oliver.
Standard User kitcat
(experienced) Mon 31-Aug-20 14:45:26
Print Post

Re: Extending BTWifi


[re: thinkbfan] [link to this post]
 
The 192.168. xxx.xxx ranges are duplicated Millions of times across the internet as they are the private ranges for every home router ever made.

The 10.xxx.xxx.xxx ranges are also duplicated across different private networks. Neither are routable to across the internet

BT wifi ( as opposed to FON) appears to have been designed to prevent what you are trying to do by limiting each session to one device for a limited amount of time per session. ( quite impressive design really). It may be that it was be accident and what they were limiting was the number of BTwifi sessions per BTHub to protect the prime customer. In that case you may find you are contending with someone else also piggy backing in the same block of flats.
Standard User gc1
(regular) Mon 31-Aug-20 20:53:19
Print Post

Re: Extending BTWifi


[re: thinkbfan] [link to this post]
 
I will pm you my OpenWrt config files - but unless you are going to change from DD-WRT to OpenWrt they probably won't mean much. I did run DD-WRT before changing to OpenWrt and that worked fine for me then to connect to BTwifi but I haven't kept any backup of that DD-WRT config.

I suggest you look at how often your DHCP client address (100.x.x.x etc.) changes. Mine stays constant as long as the router is powered up after the wifi connection is established. After the 3 hours timeout a relogin to the BTwifi gateway is required but the wifi connection was never dropped and the 100.x.x.x address remains the same. If you are getting address changes this suggests it is a wifi link problem.

Traceroute and ping to the DNS servers 192.168.22.22 and .23 also does not work for me, that traffic is blocked. A DNS query (e.g. using the dig program) does work.

I use a shell script to login. I will include this in the pm. It can run on the router or on a PC running Linux.
Pages in this thread: 1 | 2 | 3 | [4] | 5 | (show all)   Print Thread

Jump to